Update to 2.41.5
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2
3 Name:           libsoup
4 Version:        2.41.5
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          System/Libraries
10 Source:         http://download.gnome.org/sources/libsoup/2.40/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 BuildRequires:  gettext-tools
13 BuildRequires:  glib-networking
14 %if %{with gnome}
15 BuildRequires:  gobject-introspection-devel
16 BuildRequires:  pkgconfig(gnome-keyring-1)
17 %endif
18 BuildRequires:  intltool >= 0.35.0
19 BuildRequires:  sqlite3-devel
20 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
21 BuildRequires:  gnome-common
22 BuildRequires:  pkgconfig(libxml-2.0)
23
24
25 %description
26 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
27 and the glib main loop, to integrate well with GNOME applications.
28
29 Features:
30   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
31   * Automatically caches connections
32   * SSL Support using GnuTLS
33   * Proxy support, including authentication and SSL tunneling
34   * Client support for Digest, NTLM, and Basic authentication
35   * Server support for Digest and Basic authentication
36   * XML-RPC support
37
38 %package -n typelib-Soup
39 Summary:        HTTP client/server library for GNOME -- Introspection bindings
40 Group:          System/Libraries
41
42 %description -n typelib-Soup
43 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
44 and the glib main loop, to integrate well with GNOME applications.
45
46 This package provides the GObject Introspection bindings for libsoup.
47
48 %package devel
49 Summary:        HTTP client/server library for GNOME - Development Files
50 Group:          Development/Gnome
51 Requires:       %{name} = %{version}
52 %if %{with gnome}
53 Requires:       typelib-Soup = %{version}
54 %endif
55
56 %description devel
57 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
58 and the glib main loop, to integrate well with GNOME applications.
59
60 Features:
61   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
62   * Automatically caches connections
63   * SSL Support using GnuTLS
64   * Proxy support, including authentication and SSL tunneling
65   * Client support for Digest, NTLM, and Basic authentication
66   * Server support for Digest and Basic authentication
67   * XML-RPC support
68
69 %prep
70 %setup -q
71
72 %build
73 %autogen\
74 %if %{with gnome}
75     --with-gnome \
76     --enable-introspection \
77 %else
78     --without-gnome \
79     --enable-sqlite=yes \
80     --disable-tls-check \
81 %endif
82     --disable-static 
83 make %{?_smp_mflags}
84
85 %install
86 %make_install
87
88 %find_lang %{name}
89
90 %post -p /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94 %lang_package
95
96 %files
97 %defattr(-, root, root)
98 %license COPYING
99 %{_libdir}/*.so.*
100
101 %if %{with gnome}
102 %files -n typelib-Soup
103 %defattr(-,root,root)
104 %{_libdir}/girepository-1.0/Soup-2.4.typelib
105 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
106 %endif
107
108 %files devel
109 %defattr(-,root,root)
110 %{_includedir}/libsoup-2.4
111 %{_libdir}/*.so
112 %{_libdir}/pkgconfig/*.pc
113 %if %{with gnome}
114 %{_datadir}/gir-1.0/Soup-2.4.gir
115 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
116 %{_includedir}/libsoup-gnome-2.4
117 %endif