Add glib-networking to the libsoup dependency requirements.
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2
3 Name:           libsoup
4 Version:        2.42.2
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          System/Libraries
10 Source:         http://download.gnome.org/sources/libsoup/2.41/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 Source1001:     libsoup.manifest
13 Requires:       glib-networking
14 BuildRequires:  gettext-tools
15 BuildRequires:  glib-networking
16 %if %{with gnome}
17 BuildRequires:  gobject-introspection-devel
18 BuildRequires:  pkgconfig(gnome-keyring-1)
19 %endif
20 BuildRequires:  intltool >= 0.35.0
21 BuildRequires:  sqlite3-devel
22 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
23 BuildRequires:  gnome-common
24 BuildRequires:  pkgconfig(libxml-2.0)
25
26
27 %description
28 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
29 and the glib main loop, to integrate well with GNOME applications.
30
31 Features:
32   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
33   * Automatically caches connections
34   * SSL Support using GnuTLS
35   * Proxy support, including authentication and SSL tunneling
36   * Client support for Digest, NTLM, and Basic authentication
37   * Server support for Digest and Basic authentication
38   * XML-RPC support
39
40 %package -n typelib-Soup
41 Summary:        HTTP client/server library for GNOME -- Introspection bindings
42 Group:          System/Libraries
43
44 %description -n typelib-Soup
45 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
46 and the glib main loop, to integrate well with GNOME applications.
47
48 This package provides the GObject Introspection bindings for libsoup.
49
50 %package devel
51 Summary:        HTTP client/server library for GNOME - Development Files
52 Group:          Development/Gnome
53 Requires:       %{name} = %{version}
54 %if %{with gnome}
55 Requires:       typelib-Soup = %{version}
56 %endif
57
58 %description devel
59 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
60 and the glib main loop, to integrate well with GNOME applications.
61
62 Features:
63   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
64   * Automatically caches connections
65   * SSL Support using GnuTLS
66   * Proxy support, including authentication and SSL tunneling
67   * Client support for Digest, NTLM, and Basic authentication
68   * Server support for Digest and Basic authentication
69   * XML-RPC support
70
71 %prep
72 %setup -q
73 cp %{SOURCE1001} .
74
75 %build
76 %autogen\
77 %if %{with gnome}
78     --with-gnome \
79     --enable-introspection \
80 %else
81     --without-gnome \
82     --enable-sqlite=yes \
83     --disable-tls-check \
84 %endif
85     --disable-static 
86 make %{?_smp_mflags}
87
88 %install
89 %make_install
90
91 %find_lang %{name}
92
93 %post -p /sbin/ldconfig
94
95 %postun -p /sbin/ldconfig
96
97 %lang_package
98
99 %files
100 %manifest %{name}.manifest
101 %defattr(-, root, root)
102 %license COPYING
103 %{_libdir}/*.so.*
104
105 %if %{with gnome}
106 %files -n typelib-Soup
107 %manifest %{name}.manifest
108 %defattr(-,root,root)
109 %{_libdir}/girepository-1.0/Soup-2.4.typelib
110 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
111 %endif
112
113 %files devel
114 %manifest %{name}.manifest
115 %defattr(-,root,root)
116 %{_includedir}/libsoup-2.4
117 %{_libdir}/*.so
118 %{_libdir}/pkgconfig/*.pc
119 %if %{with gnome}
120 %{_datadir}/gir-1.0/Soup-2.4.gir
121 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
122 %{_includedir}/libsoup-gnome-2.4
123 %endif