Upgrade to 2.62.2
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2 %bcond_with introspection
3
4 Name:           libsoup
5 Version:        2.62.2
6 Release:        1
7 License:        LGPL-2.0+
8 Summary:        HTTP client/server library for GNOME
9 Url:            http://www.gnome.org
10 Group:          System/Libraries
11 Source:         http://download.gnome.org/sources/libsoup/2.62/%{name}-%{version}.tar.xz
12 Source99:       baselibs.conf
13 Source1001:     libsoup.manifest
14 Requires:       glib-networking
15 BuildRequires:  gettext-tools
16 BuildRequires:  glib-networking
17 %if %{with introspection}
18 BuildRequires:  gobject-introspection-devel
19 %endif
20 %if %{with gnome}
21 BuildRequires:  pkgconfig(gnome-keyring-1)
22 BuildRequires:  gnome-common
23 %endif
24 BuildRequires:  intltool >= 0.35.0
25 BuildRequires:  sqlite-devel
26 BuildRequires:  which
27 BuildRequires:  python3
28 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
29 BuildRequires:  pkgconfig(libxml-2.0)
30
31 %description
32 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
33 and the glib main loop, to integrate well with GNOME applications.
34
35 Features:
36   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
37   * Automatically caches connections
38   * SSL Support using GnuTLS
39   * Proxy support, including authentication and SSL tunneling
40   * Client support for Digest, NTLM, and Basic authentication
41   * Server support for Digest and Basic authentication
42   * XML-RPC support
43
44 %package -n typelib-Soup
45 Summary:        HTTP client/server library for GNOME -- Introspection bindings
46 Group:          System/Libraries
47
48 %description -n typelib-Soup
49 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
50 and the glib main loop, to integrate well with GNOME applications.
51
52 This package provides the GObject Introspection bindings for libsoup.
53
54 %package devel
55 Summary:        HTTP client/server library for GNOME - Development Files
56 Group:          Social & Content/GNOME
57 Requires:       %{name} = %{version}
58 %if %{with gnome}
59 Requires:       typelib-Soup = %{version}
60 %endif
61
62 %description devel
63 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
64 and the glib main loop, to integrate well with GNOME applications.
65
66 Features:
67   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
68   * Automatically caches connections
69   * SSL Support using GnuTLS
70   * Proxy support, including authentication and SSL tunneling
71   * Client support for Digest, NTLM, and Basic authentication
72   * Server support for Digest and Basic authentication
73   * XML-RPC support
74
75 %prep
76 %setup -q
77 cp %{SOURCE1001} .
78
79 %build
80 chmod +x autogen.sh
81 %autogen\
82 %if %{with introspection}
83     --enable-introspection \
84 %endif
85 %if %{with gnome}
86     --with-gnome \
87 %else
88     --without-gnome \
89     --disable-tls-check \
90 %endif
91     --disable-static \
92     --enable-vala=no
93 make %{?_smp_mflags}
94
95 %install
96 %make_install
97
98 %find_lang %{name}
99
100 %post -p /sbin/ldconfig
101
102 %postun -p /sbin/ldconfig
103
104 %lang_package
105
106 %files
107 %manifest %{name}.manifest
108 %defattr(-, root, root)
109 %license COPYING
110 %{_libdir}/*.so.*
111
112 %if %{with introspection}
113 %files -n typelib-Soup
114 %manifest %{name}.manifest
115 %defattr(-,root,root)
116 %{_libdir}/girepository-1.0/Soup-2.4.typelib
117 %if %{with gnome}
118 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
119 %endif
120 %endif
121
122 %files devel
123 %manifest %{name}.manifest
124 %defattr(-,root,root)
125 %{_includedir}/libsoup-2.4
126 %{_libdir}/*.so
127 %{_libdir}/pkgconfig/*.pc
128 %if %{with introspection}
129 %{_datadir}/gir-1.0/Soup-2.4.gir
130 %if %{with gnome}
131 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
132 %{_includedir}/libsoup-gnome-2.4
133 %endif
134 %endif