Fixed license file path
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2 %bcond_with introspection
3
4 Name:           libsoup
5 Version:        2.46.0
6 Release:        0
7 License:        LGPL-2.0+
8 Summary:        HTTP client/server library for GNOME
9 Url:            http://www.gnome.org
10 Group:          System/Libraries
11 Source:         http://download.gnome.org/sources/libsoup/2.41/%{name}-%{version}.tar.xz
12 Source99:       baselibs.conf
13 Source1001:     libsoup.manifest
14 Requires:       glib-networking
15 BuildRequires:  gettext-tools
16 BuildRequires:  glib-networking
17 %if %{with introspection}
18 BuildRequires:  gobject-introspection-devel
19 %endif
20 %if %{with gnome}
21 BuildRequires:  pkgconfig(gnome-keyring-1)
22 BuildRequires:  gnome-common
23 %endif
24 BuildRequires:  intltool >= 0.35.0
25 BuildRequires:  sqlite-devel
26 BuildRequires:  which
27 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
28 BuildRequires:  pkgconfig(libxml-2.0)
29 BuildRequires:  pkgconfig(dlog)
30
31 %description
32 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
33 and the glib main loop, to integrate well with GNOME applications.
34
35 Features:
36   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
37   * Automatically caches connections
38   * SSL Support using GnuTLS
39   * Proxy support, including authentication and SSL tunneling
40   * Client support for Digest, NTLM, and Basic authentication
41   * Server support for Digest and Basic authentication
42   * XML-RPC support
43
44 %package -n typelib-Soup
45 Summary:        HTTP client/server library for GNOME -- Introspection bindings
46 Group:          System/Libraries
47
48 %description -n typelib-Soup
49 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
50 and the glib main loop, to integrate well with GNOME applications.
51
52 This package provides the GObject Introspection bindings for libsoup.
53
54 %package devel
55 Summary:        HTTP client/server library for GNOME - Development Files
56 Group:          Social & Content/GNOME
57 Requires:       %{name} = %{version}
58 %if %{with gnome}
59 Requires:       typelib-Soup = %{version}
60 %endif
61
62 %description devel
63 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
64 and the glib main loop, to integrate well with GNOME applications.
65
66 Features:
67   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
68   * Automatically caches connections
69   * SSL Support using GnuTLS
70   * Proxy support, including authentication and SSL tunneling
71   * Client support for Digest, NTLM, and Basic authentication
72   * Server support for Digest and Basic authentication
73   * XML-RPC support
74
75 %prep
76 %setup -q
77 cp %{SOURCE1001} .
78
79 %build
80 chmod +x autogen.sh
81 %autogen\
82 %if %{with introspection}
83     --enable-introspection \
84 %endif
85 %if %{with gnome}
86     --with-gnome \
87 %else
88     --without-gnome \
89     --enable-sqlite=yes \
90     --disable-tls-check \
91 %endif
92 %if "%{TIZEN_PROFILE_TV}" == "1"
93     --enable-tizen-client-certificate=yes \
94     --enable-tizen-disable-mime-sniff \
95     --enable-tizen-text-storage-mode-of-cookie \
96     --enable-tizen-soup-cache-clean-leaked-resources \
97     --enable-tizen-tv-soup-cache-optimise-load-time \
98     --enable-tizen-use-expanded-response-block=yes \
99     --enable-tizen-create-idle-tcp-connection \
100     --enable-tizen-immediate-requesting \
101     --enable-tizen-computing-disk-cache-size \
102     --enable-tizen-add-x-soup-message-headers \
103     --enable-tizen-dynamic-certificate-loading \
104     --enable-tizen-certificate-handling \
105     --enable-tizen-tv-checking-deleted-entry-file \
106     --enable-tizen-tv-force-preload-tlsdb \
107     --enable-tizen-tv-no-cache-about-video-and-audio \
108     --enable-tizen-soup-store-dns \
109 %endif
110     --disable-static
111 make %{?_smp_mflags}
112
113 %install
114 %make_install
115
116 %find_lang %{name}
117
118 %post -p /sbin/ldconfig
119
120 %postun -p /sbin/ldconfig
121
122 %lang_package
123
124 %files
125 %manifest %{name}.manifest
126 %defattr(-, root, root)
127 %license COPYING
128 %{_libdir}/*.so.*
129
130 %if %{with introspection}
131 %files -n typelib-Soup
132 %manifest %{name}.manifest
133 %defattr(-,root,root)
134 %{_libdir}/girepository-1.0/Soup-2.4.typelib
135 %if %{with gnome}
136 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
137 %endif
138 %endif
139
140 %files devel
141 %manifest %{name}.manifest
142 %defattr(-,root,root)
143 %{_includedir}/libsoup-2.4
144 %{_libdir}/*.so
145 %{_libdir}/pkgconfig/*.pc
146 %if %{with introspection}
147 %{_datadir}/gir-1.0/Soup-2.4.gir
148 %if %{with gnome}
149 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
150 %{_includedir}/libsoup-gnome-2.4
151 %endif
152 %endif