resetting manifest requested domain to floor
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2
3 Name:           libsoup
4 Version:        2.42.2
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          System/Libraries
10 Source:         http://download.gnome.org/sources/libsoup/2.41/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 Source1001:     libsoup.manifest
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib-networking
15 %if %{with gnome}
16 BuildRequires:  gobject-introspection-devel
17 BuildRequires:  pkgconfig(gnome-keyring-1)
18 %endif
19 BuildRequires:  intltool >= 0.35.0
20 BuildRequires:  sqlite3-devel
21 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
22 BuildRequires:  gnome-common
23 BuildRequires:  pkgconfig(libxml-2.0)
24
25
26 %description
27 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
28 and the glib main loop, to integrate well with GNOME applications.
29
30 Features:
31   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
32   * Automatically caches connections
33   * SSL Support using GnuTLS
34   * Proxy support, including authentication and SSL tunneling
35   * Client support for Digest, NTLM, and Basic authentication
36   * Server support for Digest and Basic authentication
37   * XML-RPC support
38
39 %package -n typelib-Soup
40 Summary:        HTTP client/server library for GNOME -- Introspection bindings
41 Group:          System/Libraries
42
43 %description -n typelib-Soup
44 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
45 and the glib main loop, to integrate well with GNOME applications.
46
47 This package provides the GObject Introspection bindings for libsoup.
48
49 %package devel
50 Summary:        HTTP client/server library for GNOME - Development Files
51 Group:          Development/Gnome
52 Requires:       %{name} = %{version}
53 %if %{with gnome}
54 Requires:       typelib-Soup = %{version}
55 %endif
56
57 %description devel
58 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
59 and the glib main loop, to integrate well with GNOME applications.
60
61 Features:
62   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
63   * Automatically caches connections
64   * SSL Support using GnuTLS
65   * Proxy support, including authentication and SSL tunneling
66   * Client support for Digest, NTLM, and Basic authentication
67   * Server support for Digest and Basic authentication
68   * XML-RPC support
69
70 %prep
71 %setup -q
72 cp %{SOURCE1001} .
73
74 %build
75 %autogen\
76 %if %{with gnome}
77     --with-gnome \
78     --enable-introspection \
79 %else
80     --without-gnome \
81     --enable-sqlite=yes \
82     --disable-tls-check \
83 %endif
84     --disable-static 
85 make %{?_smp_mflags}
86
87 %install
88 %make_install
89
90 %find_lang %{name}
91
92 %post -p /sbin/ldconfig
93
94 %postun -p /sbin/ldconfig
95
96 %lang_package
97
98 %files
99 %manifest %{name}.manifest
100 %defattr(-, root, root)
101 %license COPYING
102 %{_libdir}/*.so.*
103
104 %if %{with gnome}
105 %files -n typelib-Soup
106 %manifest %{name}.manifest
107 %defattr(-,root,root)
108 %{_libdir}/girepository-1.0/Soup-2.4.typelib
109 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
110 %endif
111
112 %files devel
113 %manifest %{name}.manifest
114 %defattr(-,root,root)
115 %{_includedir}/libsoup-2.4
116 %{_libdir}/*.so
117 %{_libdir}/pkgconfig/*.pc
118 %if %{with gnome}
119 %{_datadir}/gir-1.0/Soup-2.4.gir
120 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
121 %{_includedir}/libsoup-gnome-2.4
122 %endif