fixed sqlite option
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2
3 Name:           libsoup
4 Version:        2.41.2
5 Release:        0
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          Development/Libraries/GNOME
10 Source:         http://download.gnome.org/sources/libsoup/2.40/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 BuildRequires:  gettext-tools
13 BuildRequires:  glib-networking
14 %if %{with gnome}
15 BuildRequires:  gobject-introspection-devel
16 BuildRequires:  pkgconfig(gnome-keyring-1)
17 %endif
18 BuildRequires:  intltool >= 0.35.0
19 BuildRequires:  sqlite3-devel
20 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
21 BuildRequires:  gnome-common
22 BuildRequires:  pkgconfig(libxml-2.0)
23
24 %description
25 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
26 and the glib main loop, to integrate well with GNOME applications.
27
28 Features:
29   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
30   * Automatically caches connections
31   * SSL Support using GnuTLS
32   * Proxy support, including authentication and SSL tunneling
33   * Client support for Digest, NTLM, and Basic authentication
34   * Server support for Digest and Basic authentication
35   * XML-RPC support
36
37 %package -n typelib-Soup
38 Summary:        HTTP client/server library for GNOME -- Introspection bindings
39 Group:          System/Libraries
40
41 %description -n typelib-Soup
42 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
43 and the glib main loop, to integrate well with GNOME applications.
44
45 This package provides the GObject Introspection bindings for libsoup.
46
47 %package devel
48 Summary:        HTTP client/server library for GNOME - Development Files
49 Group:          Development/Libraries/GNOME
50 Requires:       %{name} = %{version}
51 %if %{with gnome}
52 Requires:       typelib-Soup = %{version}
53 %endif
54
55 %description devel
56 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
57 and the glib main loop, to integrate well with GNOME applications.
58
59 Features:
60   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
61   * Automatically caches connections
62   * SSL Support using GnuTLS
63   * Proxy support, including authentication and SSL tunneling
64   * Client support for Digest, NTLM, and Basic authentication
65   * Server support for Digest and Basic authentication
66   * XML-RPC support
67
68 %prep
69 %setup -q
70
71 %build
72 %autogen\
73 %if %{with gnome}
74     --with-gnome \
75     --enable-introspection \
76 %else
77     --without-gnome \
78     --enable-sqlite=yes \
79     --disable-tls-check \
80 %endif
81     --disable-static 
82 make %{?_smp_mflags}
83
84 %install
85 %make_install
86
87 %find_lang %{name}
88
89 %post -p /sbin/ldconfig
90
91 %postun -p /sbin/ldconfig
92
93 %lang_package
94
95 %files
96 %defattr(-, root, root)
97 %license COPYING
98 %{_libdir}/*.so.*
99
100 %if %{with gnome}
101 %files -n typelib-Soup
102 %defattr(-,root,root)
103 %{_libdir}/girepository-1.0/Soup-2.4.typelib
104 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
105 %endif
106
107 %files devel
108 %defattr(-,root,root)
109 %{_includedir}/libsoup-2.4
110 %{_libdir}/*.so
111 %{_libdir}/pkgconfig/*.pc
112 %if %{with gnome}
113 %{_datadir}/gir-1.0/Soup-2.4.gir
114 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
115 %{_includedir}/libsoup-gnome-2.4
116 %endif