make gnome builds optional
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %bcond_with gnome
2
3 Name:           libsoup
4 Version:        2.40.1
5 Release:        2.1
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          Development/Libraries/GNOME
10 Source:         http://download.gnome.org/sources/libsoup/2.40/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 # Patches auto-generated by git-buildpackage:
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib-networking
15 %if %{with gnome}
16 BuildRequires:  gobject-introspection-devel
17 %endif
18 BuildRequires:  intltool >= 0.35.0
19 BuildRequires:  sqlite3-devel
20 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.7
21 BuildRequires:  gnome-common
22 BuildRequires:  pkgconfig(libxml-2.0)
23
24 %description
25 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
26 and the glib main loop, to integrate well with GNOME applications.
27
28 Features:
29   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
30   * Automatically caches connections
31   * SSL Support using GnuTLS
32   * Proxy support, including authentication and SSL tunneling
33   * Client support for Digest, NTLM, and Basic authentication
34   * Server support for Digest and Basic authentication
35   * XML-RPC support
36
37 %package -n typelib-Soup
38 Summary:        HTTP client/server library for GNOME -- Introspection bindings
39 Group:          System/Libraries
40
41 %description -n typelib-Soup
42 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
43 and the glib main loop, to integrate well with GNOME applications.
44
45 This package provides the GObject Introspection bindings for libsoup.
46
47 %package devel
48 Summary:        HTTP client/server library for GNOME - Development Files
49 Group:          Development/Libraries/GNOME
50 Requires:       %{name} = %{version}
51 Requires:       typelib-Soup = %{version}
52
53 %description devel
54 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
55 and the glib main loop, to integrate well with GNOME applications.
56
57 Features:
58   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
59   * Automatically caches connections
60   * SSL Support using GnuTLS
61   * Proxy support, including authentication and SSL tunneling
62   * Client support for Digest, NTLM, and Basic authentication
63   * Server support for Digest and Basic authentication
64   * XML-RPC support
65
66 %prep
67 %setup -q
68
69 %build
70 %autogen\
71 %if %{with gnome}
72      --with-gnome \
73     --enable-introspection
74 %else
75      --without-gnome \
76      --enable-sqllite=yes \
77     --disable-tls-check \
78 %endif
79     --disable-static 
80 make %{?_smp_mflags}
81
82 %install
83 %make_install
84
85 %find_lang %{name}
86
87 %post -p /sbin/ldconfig
88
89 %postun -p /sbin/ldconfig
90
91 %lang_package
92
93 %files
94 %defattr(-, root, root)
95 %license  COPYING
96 %{_libdir}/*.so.*
97
98 %files -n typelib-Soup
99 %defattr(-,root,root)
100 %if %{with gnome}
101 %{_libdir}/girepository-1.0/Soup-2.4.typelib
102 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
103 %endif
104
105 %files devel
106 %defattr(-,root,root)
107 %{_includedir}/libsoup-2.4
108 %{_libdir}/*.so
109 %{_libdir}/pkgconfig/*.pc
110 %if %{with gnome}
111 %{_datadir}/gir-1.0/Soup-2.4.gir
112 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
113 %{_includedir}/libsoup-gnome-2.4
114 %endif