require gnome-common
[platform/upstream/libsoup.git] / packaging / libsoup.spec
1 %define enable_gnome 0
2
3 Name:           libsoup
4 Version:        2.40.1
5 Release:        2.1
6 License:        LGPL-2.1+
7 Summary:        HTTP client/server library for GNOME
8 Url:            http://www.gnome.org
9 Group:          Development/Libraries/GNOME
10 Source:         http://download.gnome.org/sources/libsoup/2.40/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 # Patches auto-generated by git-buildpackage:
13 BuildRequires:  gettext-tools
14 BuildRequires:  glib-networking
15 BuildRequires:  gobject-introspection-devel
16 BuildRequires:  gtk-doc
17 BuildRequires:  intltool >= 0.35.0
18 BuildRequires:  sqlite3-devel
19 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.7
20 BuildRequires:  gnome-common
21 BuildRequires:  pkgconfig(libxml-2.0)
22
23 %description
24 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
25 and the glib main loop, to integrate well with GNOME applications.
26
27 Features:
28   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
29   * Automatically caches connections
30   * SSL Support using GnuTLS
31   * Proxy support, including authentication and SSL tunneling
32   * Client support for Digest, NTLM, and Basic authentication
33   * Server support for Digest and Basic authentication
34   * XML-RPC support
35
36 %package -n typelib-Soup
37 Summary:        HTTP client/server library for GNOME -- Introspection bindings
38 Group:          System/Libraries
39
40 %description -n typelib-Soup
41 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
42 and the glib main loop, to integrate well with GNOME applications.
43
44 This package provides the GObject Introspection bindings for libsoup.
45
46 %package devel
47 Summary:        HTTP client/server library for GNOME - Development Files
48 Group:          Development/Libraries/GNOME
49 Requires:       %{name} = %{version}
50 Requires:       typelib-Soup = %{version}
51
52 %description devel
53 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
54 and the glib main loop, to integrate well with GNOME applications.
55
56 Features:
57   * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
58   * Automatically caches connections
59   * SSL Support using GnuTLS
60   * Proxy support, including authentication and SSL tunneling
61   * Client support for Digest, NTLM, and Basic authentication
62   * Server support for Digest and Basic authentication
63   * XML-RPC support
64
65 %prep
66 %setup -q
67
68 %build
69 %autogen\
70     --disable-static \
71 %if 0%{!enable_gnome}
72      --with-gnome \
73 %else
74      --without-gnome \
75      --enable-sqllite=yes \
76     --disable-tls-check \
77 %endif
78     --enable-introspection
79 make %{?_smp_mflags}
80
81 %install
82 %make_install
83
84 %find_lang %{name}
85
86 %post -p /sbin/ldconfig
87
88 %postun -p /sbin/ldconfig
89
90 %lang_package
91
92 %files
93 %defattr(-, root, root)
94 %license  COPYING
95 %{_libdir}/*.so.*
96
97 %files -n typelib-Soup
98 %defattr(-,root,root)
99 %{_libdir}/girepository-1.0/Soup-2.4.typelib
100 %if 0%{!enable_gnome}
101 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
102 %endif
103
104 %files devel
105 %defattr(-,root,root)
106 %{_includedir}/libsoup-2.4
107 %{_libdir}/*.so
108 %{_libdir}/pkgconfig/*.pc
109 %{_datadir}/gir-1.0/Soup-2.4.gir
110 %if 0%{!enable_gnome}
111 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
112 %{_includedir}/libsoup-gnome-2.4
113 %endif