add packaging
[platform/upstream/libsmi.git] / packaging / libsmi.spec
1 Name:           libsmi
2 Version:        0.4.8
3 Release:        2
4 License:        MIT
5 Summary:        A Library to Access SMI MIB Information
6 Url:            http://www.ibr.cs.tu-bs.de/projects/libsmi
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 BuildRequires:  bison
10 BuildRequires:  flex
11 BuildRequires:  libtool
12
13 %description
14 The purpose of libsmi is to
15
16 * Give network management applications a concise programmer-friendly
17    interface to access MIB module information
18
19 * Separate the knowledge on SMI from the main parts of management
20    applications
21
22 * Allow addition of new kinds of MIB repositories without the need to
23 adapt applications that make use of libsmi
24
25 %package devel
26 License:        MIT
27 Summary:        Libsmi Header Files And Static Libraries
28 Group:          Development/Libraries/C and C++
29 Requires:       %{name} = %{version}
30 Requires:       glibc-devel
31
32 %description devel
33 This package contains the header files and static libraries of package
34 libsmi.
35
36 %prep
37 %setup -q
38
39 %build
40 autoreconf --force --install
41 %configure --disable-static --with-pic --enable-smi \
42         --enable-sming \
43         --with-mibdir=%{_datadir}/mibs
44
45 make %{?_smp_mflags}
46
47 %install
48 %make_install
49
50 %post -n libsmi -p /sbin/ldconfig
51
52 %postun -n libsmi -p /sbin/ldconfig
53
54
55 %docs_package
56
57 %files
58 %defattr(-, root, root)
59 %doc COPYING 
60 %{_bindir}/*
61 %{_datadir}/mibs
62 %{_datadir}/pibs
63 %{_libdir}/libsmi.so.*
64
65
66 %files devel
67 %defattr(-, root, root)
68 %{_includedir}/*
69 %{_libdir}/libsmi.so
70 %{_libdir}/pkgconfig/libsmi.pc
71 %{_datadir}/aclocal/libsmi.m4
72
73 %changelog