upload tizen1.0 source
[profile/ivi/libslp-utilx.git] / packaging / libslp-utilx.spec
1 Name:       libslp-utilx
2 Summary:    utilX 
3 Version:        0.1.7
4 Release:    1.1
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10
11 BuildRequires: cmake
12 BuildRequires: pkgconfig(x11)
13
14 %description
15 Utility functions for the XWindow
16
17
18 %package devel
19 Summary:    utilX
20 Group:      Development/Libraries
21 Requires:   %{name} = %{version}-%{release}
22
23 %description devel
24 Utility functions for the XWindow (developement files)
25
26 %prep
27 %setup -q
28
29
30 %build
31 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
32
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40
41 %post -p /sbin/ldconfig
42
43 %postun -p /sbin/ldconfig
44
45
46 %files
47 %defattr(-,root,root,-)
48 /usr/lib/libutilX.so.*
49
50
51 %files devel
52 %defattr(-,root,root,-)
53 /usr/include/utilX.h
54 /usr/lib/libutilX.so
55 /usr/lib/pkgconfig/utilX.pc
56
57
58
59