Generate Licence file
[framework/telephony/libslp-tapi.git] / packaging / libslp-tapi.spec
1 Name: libslp-tapi
2 Summary: Telephony dbus client library
3 Version: 0.6.70
4 Release:    2
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    libslp-tapi-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(gobject-2.0)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(security-server)
13
14 %description
15 Telephony client API library
16
17 %package devel
18 Summary:    Telephony client API (devel)
19 Group:      Development/Libraries
20 Requires:   %{name} = %{version}-%{release}
21
22 %description devel
23 Telephony client API library (devel)
24
25
26 %prep
27 %setup -q
28
29
30 %build
31 %cmake .
32
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 rm -rf %{buildroot}/usr/include/telephony/tapi/.gitignore
41 mkdir -p %{buildroot}/usr/share/license
42 cp LICENSE %{buildroot}/usr/share/license/%{name}
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48
49 %files
50 %manifest libslp-tapi.manifest
51 %defattr(-,root,root,-)
52 %{_libdir}/*.so.*
53 /usr/share/license/%{name}
54
55 %files devel
56 %defattr(-,root,root,-)
57 %{_includedir}/telephony-client/*.h
58 %{_libdir}/pkgconfig/*.pc
59 %{_libdir}/*.so