copy license file to /usr/share/license/
[framework/system/libslp-pm.git] / packaging / libslp-pm.spec
1 Name:       libslp-pm
2 Summary:    Power manager library
3 Version:    1.2.4
4 Release:    2.1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    libslp-pm-%{version}.tar.bz2
8 BuildRequires:  cmake
9
10
11 %description
12 Samsung Linux platform power manager client library
13
14
15
16 %package devel
17 Summary:    SLP power manager client (devel)
18 Group:      Development/Libraries
19 Requires:   %{name} = %{version}-%{release}
20 Requires:   libslp-pm
21
22 %description devel
23 SLP power manager client library (devel)
24
25
26 %prep
27 %setup -q 
28
29
30 %build
31 %cmake .
32
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 mkdir -p %{buildroot}%{_datadir}/license
41 cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48
49 %files
50 %defattr(-,root,root,-)
51 %manifest libslp-pm.manifest
52 %{_libdir}/libpmapi.so.1.2
53 %{_datadir}/license/%{name}
54
55 %files devel
56 %defattr(-,root,root,-)
57 %{_includedir}/pmapi.h
58 %{_includedir}/pmapi_managed.h
59 %{_includedir}/SLP_pm_PG.h
60 %{_libdir}/pkgconfig/pmapi.pc
61 %{_libdir}/libpmapi.so
62