Add default Smack manifest for libslp-pm.spec
[framework/system/libslp-pm.git] / packaging / libslp-pm.spec
1 Name:       libslp-pm
2 Summary:    Power manager library
3 Version:    1.2.4
4 Release:    2.1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    libslp-pm-%{version}.tar.bz2
8 Source1001: packaging/libslp-pm.manifest 
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12
13
14 %description
15 Samsung Linux platform power manager client library
16
17
18
19 %package devel
20 Summary:    SLP power manager client (devel)
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23 Requires:   libslp-pm
24
25 %description devel
26 SLP power manager client library (devel)
27
28
29 %prep
30 %setup -q 
31
32
33 %build
34 cp %{SOURCE1001} .
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
36
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49
50
51 %files
52 %manifest libslp-pm.manifest
53 %defattr(-,root,root,-)
54 %{_libdir}/libpmapi.so.1.2
55
56
57 %files devel
58 %manifest libslp-pm.manifest
59 %defattr(-,root,root,-)
60 %{_includedir}/pmapi.h
61 %{_includedir}/SLP_pm_PG.h
62 %{_libdir}/pkgconfig/pmapi.pc
63 %{_libdir}/libpmapi.so
64