Bump to libsigc++ 2.10.7
[platform/upstream/libsigc++.git] / packaging / libsigc++.spec
1 #
2 # spec file for package libsigc++2
3 #
4 # Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via https://bugs.opensuse.org/
16 #
17
18
19 Name:           libsigc++
20 Version:        2.10.7
21 Release:        0
22 Summary:        Typesafe Signal Framework for C++
23 License:        LGPL-2.1+
24 Group:          Development/Libraries/C and C++
25 URL:            https://github.com/libsigcplusplus/libsigcplusplus
26 Source:         https://download.gnome.org/sources/libsigc++/2.10/%{name}-%{version}.tar.xz
27 Source1001:     %{name}.manifest
28 Source1002:     fix_autogen_to_build_in_tizen.patch
29 BuildRequires:  m4
30 BuildRequires:  pkgconfig
31 BuildRequires:  mm-common
32 BuildRequires:  xsltproc
33 BuildRequires:  doxygen
34
35 %description
36 This library implements a full callback system for use in widget
37 libraries, abstract interfaces, and general programming. It is the most
38 complete library of its kind with the ability to connect an abstract
39 callback to a class method, function, or function object. It contains
40 adaptor classes for connection of dissimilar callbacks and has an ease
41 of use unmatched by other C++ callback libraries.
42
43 %package devel
44 Summary:        Typesafe Signal Framework for C++
45 Group:          Development/Libraries/C and C++
46 Requires:       %{name} = %{version}
47
48 %description devel
49 This library implements a full callback system for use in widget
50 libraries, abstract interfaces, and general programming. It is the most
51 complete library of its kind with the ability to connect an abstract
52 callback to a class method, function, or function object. It contains
53 adaptor classes for connection of dissimilar callbacks and has an ease
54 of use unmatched by other C++ callback libraries.
55
56 %prep
57 %setup -q -n %{name}-%{version}
58 cp %{SOURCE1001} .
59 %{__patch} -p1 < %{SOURCE1002}
60
61 %build
62 ./autogen.sh
63 %configure --enable-maintainer-mode --disable-static
64 make %{?_smp_mflags}
65
66 %install
67 %make_install
68 find %{buildroot} -type f -name "*.la" -delete -print
69
70 %check
71 export MALLOC_CHECK_=2 MALLOC_PERTURB_=$((${RANDOM:-256} % 256))
72 make %{?_smp_mflags} check
73 unset MALLOC_CHECK_ MALLOC_PERTURB_
74
75 %post -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %license COPYING
80 %manifest %{name}.manifest
81 %doc AUTHORS ChangeLog NEWS README
82 %{_libdir}/libsigc-2.0.so*
83
84 %files devel
85 %license COPYING
86 %manifest %{name}.manifest
87 %{_libdir}/libsigc-2.0.so
88 %{_libdir}/pkgconfig/sigc++-2.0.pc
89 %{_libdir}/sigc++-2.0/*
90 %{_includedir}/sigc++-2.0/*