Fix the prevent warnings
[platform/core/appfw/shortcut.git] / packaging / libshortcut.spec
1 Name: libshortcut
2 Summary: Shortcut add feature supporting library
3 Version: 0.6.12
4 Release: 0
5 Group: HomeTF/Framework
6 License: Apache
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12
13 BuildRequires: cmake, gettext-tools, coreutils
14 BuildRequires: pkgconfig(glib-2.0)
15 BuildRequires: pkgconfig(dlog)
16 BuildRequires: pkgconfig(db-util)
17 BuildRequires: pkgconfig(sqlite3)
18 BuildRequires: pkgconfig(com-core)
19 BuildRequires: pkgconfig(libxml-2.0)
20 BuildRequires: pkgconfig(vconf)
21
22 %description
23 [Shortcut] AddToHome feature supporting library for menu/home screen developers.
24
25 %package devel
26 Summary:    AddToHome feature supporting library development files
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 [Shortcut] AddToHome feature supporting library for menu/home screen developers
32 (dev).
33
34 %prep
35 %setup -q
36 cp %{SOURCE1001} .
37
38 %build
39 %if 0%{?sec_build_binary_debug_enable}
40 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
41 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
42 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
43 %endif
44 %if 0%{?tizen_build_binary_release_type_eng}
45 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
46 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
47 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
48 %endif
49 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
50 make %{?jobs:-j%jobs}
51
52 %install
53 rm -rf %{buildroot}
54 %make_install
55 mkdir -p %{buildroot}/opt/dbspace
56 touch %{buildroot}/opt/dbspace/.shortcut_service.db
57 touch %{buildroot}/opt/dbspace/.shortcut_service.db-journal
58
59 %post
60
61 %postun
62
63 %files -n libshortcut
64 %manifest %{name}.manifest
65 %defattr(-,root,root,-)
66 %{_libdir}/*.so*
67 %{_prefix}/etc/package-manager/parserlib/*
68 %{_datarootdir}/license/*
69 %attr(640,root,app) /opt/dbspace/.shortcut_service.db
70 %attr(640,root,app) /opt/dbspace/.shortcut_service.db-journal
71
72 %files devel
73 %manifest %{name}.manifest
74 %defattr(-,root,root,-)
75 %{_includedir}/shortcut/shortcut.h
76 %{_libdir}/pkgconfig/shortcut.pc
77
78 # End of a file