Merge branch 'devel/home/master'
[platform/core/appfw/shortcut.git] / packaging / libshortcut.spec
1 Name: libshortcut
2 Summary: Shortcut add feature supporting library
3 Version: 0.6.7
4 Release: 0
5 Group: HomeTF/Framework
6 License: Apache License
7 Source0: %{name}-%{version}.tar.gz
8
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12 BuildRequires: cmake, gettext-tools, coreutils
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(db-util)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(com-core)
18 BuildRequires: pkgconfig(libxml-2.0)
19 BuildRequires: pkgconfig(vconf)
20
21 %description
22 [Shortcut] AddToHome feature supporting library for menu/home screen developers.
23
24 %package devel
25 Summary:    AddToHome feature supporting library development files
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 [Shortcut] AddToHome feature supporting library for menu/home screen developers
31 (dev).
32
33 %prep
34 %setup -q
35
36 %build
37 %if 0%{?tizen_build_binary_release_type_eng}
38 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
39 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
40 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
41 %endif
42 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 %make_install
48 mkdir -p %{buildroot}/opt/dbspace
49 touch %{buildroot}/opt/dbspace/.shortcut_service.db
50 touch %{buildroot}/opt/dbspace/.shortcut_service.db-journal
51
52 %post
53
54 %postun
55
56 %files -n libshortcut
57 %manifest libshortcut.manifest
58 %defattr(-,root,root,-)
59 %{_libdir}/*.so*
60 %{_prefix}/etc/package-manager/parserlib/*
61 %{_datarootdir}/license/*
62 %attr(640,root,app) /opt/dbspace/.shortcut_service.db
63 %attr(640,root,app) /opt/dbspace/.shortcut_service.db-journal
64
65 %files devel
66 %defattr(-,root,root,-)
67 %{_includedir}/shortcut/shortcut_PG.h
68 %{_includedir}/shortcut/shortcut.h
69 %{_libdir}/pkgconfig/shortcut.pc
70
71 # End of a file