Tizen 2.0 Release
[framework/appfw/shortcut.git] / packaging / libshortcut.spec
1 Name:       libshortcut
2 Summary:    Shortcut add feature supporting library
3 Version:    0.0.5
4 Release:    0
5 Group:      main/devel
6 License:    Apache License
7 Source0:    %{name}-%{version}.tar.gz
8
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12 BuildRequires: cmake, gettext-tools
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: pkgconfig(dlog)
15
16 %description
17 [Shortcut] AddToHome feature supporting library for menu/home screen developers.
18
19 %package devel
20 Summary:    AddToHome feature supporting library development files
21 Group:      Development/Libraries
22 Requires:   %{name} = %{version}-%{release}
23
24 %description devel
25 [Shortcut] AddToHome feature supporting library for menu/home screen developers
26 (dev).
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38
39 %post
40
41 %postun
42
43 %files -n libshortcut
44 %manifest libshortcut.manifest
45 %defattr(-,root,root,-)
46 %{_libdir}/*.so*
47
48 %files devel
49 %defattr(-,root,root,-)
50 %{_includedir}/shortcut/SLP_shortcut_PG.h
51 %{_includedir}/shortcut/shortcut.h
52 %{_libdir}/pkgconfig/shortcut.pc