2 Summary: Shortcut add feature supporting library
5 Group: HomeTF/Framework
6 License: Apache License
7 Source0: %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
12 BuildRequires: cmake, gettext-tools, coreutils
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(db-util)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(com-core)
18 BuildRequires: pkgconfig(libxml-2.0)
19 BuildRequires: pkgconfig(vconf)
22 [Shortcut] AddToHome feature supporting library for menu/home screen developers.
25 Summary: AddToHome feature supporting library development files
26 Group: Development/Libraries
27 Requires: %{name} = %{version}-%{release}
30 [Shortcut] AddToHome feature supporting library for menu/home screen developers
37 %if 0%{?tizen_build_binary_release_type_eng}
38 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
39 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
40 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
42 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
48 mkdir -p %{buildroot}/opt/dbspace
49 touch %{buildroot}/opt/dbspace/.shortcut_service.db
50 touch %{buildroot}/opt/dbspace/.shortcut_service.db-journal
57 %manifest libshortcut.manifest
58 %defattr(-,root,root,-)
60 %{_prefix}/etc/package-manager/parserlib/*
61 %{_datarootdir}/license/*
62 %attr(640,root,app) /opt/dbspace/.shortcut_service.db
63 %attr(640,root,app) /opt/dbspace/.shortcut_service.db-journal
66 %defattr(-,root,root,-)
67 %{_includedir}/shortcut/shortcut_PG.h
68 %{_includedir}/shortcut/shortcut.h
69 %{_libdir}/pkgconfig/shortcut.pc