Update the project to the newest version.
[framework/appfw/shortcut.git] / packaging / libshortcut.spec
1 Name: libshortcut
2 Summary: Shortcut add feature supporting library
3 Version: 0.3.12
4 Release: 0
5 Group: main/devel
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12 BuildRequires: cmake, gettext-tools
13 BuildRequires: pkgconfig(glib-2.0)
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(db-util)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(com-core)
18 BuildRequires: pkgconfig(libxml-2.0)
19 BuildRequires: pkgconfig(vconf)
20
21 %description
22 [Shortcut] AddToHome feature supporting library for menu/home screen developers.
23
24 %package devel
25 Summary:    AddToHome feature supporting library development files
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 [Shortcut] AddToHome feature supporting library for menu/home screen developers
31 (dev).
32
33 %prep
34 %setup -q
35
36 %build
37 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 %post
45
46 %postun
47
48 %files -n libshortcut
49 %manifest libshortcut.manifest
50 %defattr(-,root,root,-)
51 /usr/lib/*.so*
52 /usr/etc/package-manager/parserlib/*
53 /usr/share/license/*
54
55 %files devel
56 %defattr(-,root,root,-)
57 /usr/include/shortcut/shortcut_PG.h
58 /usr/include/shortcut/shortcut.h
59 /usr/lib/pkgconfig/shortcut.pc