89006a0cb9a77746d9a05272871496a75d9ebafb
[platform/upstream/libsecret.git] / packaging / libsecret.spec
1 %define have_lang 1
2
3 Name:           libsecret
4 Version:        0.10
5 Release:        2.1
6 Summary:        Library for accessing the Secret Service API
7 License:        LGPL-2.1+
8 Group:          System/Libraries
9 Url:            http://www.gnome.org/
10 Source0:        http://download.gnome.org/sources/libsecret/0.10/%{name}-%{version}.tar.xz
11 Source99:       baselibs.conf
12 BuildRequires:  gettext-tools
13 BuildRequires:  docbook-xsl-stylesheets
14 BuildRequires:  fdupes
15 BuildRequires:  gobject-introspection-devel >= 1.29
16 BuildRequires:  intltool
17 BuildRequires:  libgcrypt-devel >= 1.2.2
18 BuildRequires:  vala >= 0.17.2.12
19 BuildRequires:  xsltproc
20 BuildRequires:  pkgconfig(gio-2.0) >= 2.31.0
21 BuildRequires:  pkgconfig(gio-unix-2.0)
22 BuildRequires:  pkgconfig(glib-2.0) >= 2.31.0
23 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
24
25 %description
26 libsecret is a library for storing and retrieving passwords and other
27 secrets. It communicates with the "Secret Service" using DBus.
28
29 Summary:        Library for accessing the Secret Service API
30 Group:          System/Libraries
31 Recommends:     %{name}-lang
32
33 %package -n typelib-Secret
34 Summary:        Library for accessing the Secret Service API -- Introspection bindings
35 Group:          System/Libraries
36
37 %description -n typelib-Secret
38 libsecret is a library for storing and retrieving passwords and other
39 secrets. It communicates with the "Secret Service" using DBus.
40
41 This package provides the GObject Introspection bindings for libsecret.
42
43 %package -n typelib-SecretUnstable
44 Summary:        Library for accessing the Secret Service API -- Introspection bindings
45 Group:          System/Libraries
46
47 %description -n typelib-SecretUnstable
48 libsecret is a library for storing and retrieving passwords and other
49 secrets. It communicates with the "Secret Service" using DBus.
50
51 This package provides the GObject Introspection bindings for libsecret.
52
53 %package tools
54 Summary:        Library for accessing the Secret Service API -- Tools
55 Group:          System/Libraries
56
57 %description tools
58 libsecret is a library for storing and retrieving passwords and other
59 secrets. It communicates with the "Secret Service" using DBus.
60
61 %package devel
62 Summary:        Library for accessing the Secret Service API -- Development Files
63 Group:          Development/Libraries/GNOME
64 Requires:       libsecret = %{version}
65 Requires:       typelib-Secret = %{version}
66 Requires:       typelib-SecretUnstable = %{version}
67
68 %description devel
69 libsecret is a library for storing and retrieving passwords and other
70 secrets. It communicates with the "Secret Service" using DBus.
71
72 %lang_package
73 %prep
74 %setup -q
75
76 %build
77 %configure \
78         --disable-static
79 make V=1
80
81 %install
82 %make_install
83 %find_lang %{name}
84 rm -rf %{buildroot}%{_datadir}/locales/*
85 %fdupes %{buildroot}
86
87 %post -p /sbin/ldconfig
88
89 %postun -p /sbin/ldconfig
90
91 %files 
92 %defattr (-, root, root)
93 %doc AUTHORS ChangeLog COPYING NEWS README
94 %{_libdir}/libsecret-1.so.*
95
96 %files -n typelib-Secret
97 %defattr(-,root,root)
98 %{_libdir}/girepository-1.0/Secret-1.typelib
99
100 %files -n typelib-SecretUnstable
101 %defattr(-,root,root)
102 %{_libdir}/girepository-1.0/SecretUnstable-0.typelib
103
104 %files tools
105 %defattr(-,root,root)
106 %{_bindir}/secret-tool
107 %{_mandir}/man1/secret-tool.1%{?ext_man}
108
109 %files devel
110 %defattr (-, root, root)
111 %{_libdir}/libsecret-1.so
112 %{_libdir}/pkgconfig/libsecret-1.pc
113 %{_libdir}/pkgconfig/libsecret-unstable.pc
114 %{_includedir}/libsecret-1/
115 %{_datadir}/gir-1.0/Secret-1.gir
116 %{_datadir}/gir-1.0/SecretUnstable-0.gir
117 %doc %{_datadir}/gtk-doc/html/libsecret-1/
118 %dir %{_datadir}/vala/vapi
119 %{_datadir}/vala/vapi/libsecret-1.deps
120 %{_datadir}/vala/vapi/libsecret-1.vapi
121 %{_datadir}/vala/vapi/libsecret-unstable.deps
122 %{_datadir}/vala/vapi/libsecret-unstable.vapi
123 %{_datadir}/vala/vapi/mock-service-0.vapi