Update package version to 0.6.38
[platform/core/uifw/libscl-ui.git] / packaging / libscl-ui.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       libscl-ui
5 Summary:    A library for developing XML-based software keyboards
6 Version:    0.6.38
7 Release:    1
8 Group:      Graphics & UI Framework/Input
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(elementary)
13 %if %{with wayland}
14 %else
15 BuildRequires:  pkgconfig(ecore-x)
16 BuildRequires:  pkgconfig(x11)
17 %endif
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  pkgconfig(feedback)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(libxml-2.0)
23 BuildRequires:  pkgconfig(tts)
24 BuildRequires:  pkgconfig(libscl-common)
25
26
27 %description
28 A library that helps developing S/W Keyboard
29
30 %package devel
31 Summary:    SCL-UI header file
32 Group:      Development/Libraries
33 Requires:   %{name} = %{version}-%{release}
34
35 %description devel
36 A devel package of libscl-ui library that helps developing S/W Keyboard
37
38 %prep
39 %setup -q
40
41
42 %build
43 rm -rf CMakeFiles
44 rm -rf CMakeCache.txt
45
46 %if "%{profile}" == "wearable"
47 CFLAGS+=" -D_WEARABLE";
48 CXXFLAGS+=" -D_WEARABLE";
49 %endif
50
51 %if "%{profile}" == "mobile"
52 CFLAGS+=" -D_MOBILE";
53 CXXFLAGS+=" -D_MOBILE";
54 %endif
55
56 %if "%{profile}" == "tv"
57 CFLAGS+=" -D_TV";
58 CXXFLAGS+=" -D_TV";
59 %endif
60
61 %if %{with wayland}
62 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
63 %else
64 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
65 %endif
66 make %{?_smp_mflags}
67
68 %install
69 rm -rf %{buildroot}
70
71 %make_install
72
73
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %files
80 %manifest %{name}.manifest
81 %defattr(-,root,root,-)
82 %{_libdir}/%{name}.so
83 %{_datadir}/%{name}/metadata.xml
84 %license LICENSE
85
86 %files devel
87 %defattr(-,root,root,-)
88 %{_includedir}/*
89 %{_libdir}/pkgconfig/%{name}.pc
90 %{_bindir}/xml2binary