Update package version to 0.6.25
[platform/core/uifw/libscl-ui.git] / packaging / libscl-ui.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       libscl-ui
5 Summary:    A library for developing XML-based software keyboards
6 Version:    0.6.25
7 Release:    1
8 Group:      Graphics & UI Framework/Input
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(elementary)
13 %if %{with wayland}
14 %else
15 BuildRequires:  pkgconfig(ecore-x)
16 BuildRequires:  pkgconfig(x11)
17 %endif
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(feedback)
20 BuildRequires:  pkgconfig(dlog)
21 BuildRequires:  pkgconfig(libxml-2.0)
22 BuildRequires:  pkgconfig(tts)
23 BuildRequires:  pkgconfig(libscl-common)
24
25
26 %description
27 A library that helps developing S/W Keyboard
28
29 %package devel
30 Summary:    SCL-UI header file
31 Group:      Development/Libraries
32 Requires:   %{name} = %{version}-%{release}
33
34 %description devel
35 A devel package of libscl-ui library that helps developing S/W Keyboard
36
37 %prep
38 %setup -q
39
40
41 %build
42 rm -rf CMakeFiles
43 rm -rf CMakeCache.txt
44
45 %if "%{profile}" == "wearable"
46 CFLAGS+=" -D_WEARABLE";
47 CXXFLAGS+=" -D_WEARABLE";
48 %endif
49
50 %if "%{profile}" == "mobile"
51 CFLAGS+=" -D_MOBILE";
52 CXXFLAGS+=" -D_MOBILE";
53 %endif
54
55 %if "%{profile}" == "tv"
56 CFLAGS+=" -D_TV";
57 CXXFLAGS+=" -D_TV";
58 %endif
59
60 %if %{with wayland}
61 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
62 %else
63 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
64 %endif
65 make %{?_smp_mflags}
66
67 %install
68 rm -rf %{buildroot}
69
70 %make_install
71
72
73
74 %post -p /sbin/ldconfig
75
76 %postun -p /sbin/ldconfig
77
78 %files
79 %manifest %{name}.manifest
80 %defattr(-,root,root,-)
81 %{_libdir}/%{name}.so
82 %{_datadir}/%{name}/metadata.xml
83 %license LICENSE
84
85 %files devel
86 %defattr(-,root,root,-)
87 %{_includedir}/*
88 %{_libdir}/pkgconfig/%{name}.pc
89 %{_bindir}/xml2binary