Update package version to 0.5.3
[platform/core/uifw/libscl-ui.git] / packaging / libscl-ui.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %define _optdir /opt
5 %define _appdir %{_optdir}/apps
6
7 Name:       libscl-ui
8 Summary:    A library for developing XML-based software keyboards
9 Version:    0.5.3
10 Release:    1
11 Group:      Graphics & UI Framework/Input
12 License:    Apache-2.0
13 Source0:    libscl-ui-%{version}.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(elementary)
17 %if %{with wayland}
18 %else
19 BuildRequires:  pkgconfig(utilX)
20 BuildRequires:  pkgconfig(x11)
21 %endif
22 BuildRequires:  pkgconfig(vconf)
23 BuildRequires:  pkgconfig(feedback)
24 BuildRequires:  pkgconfig(sensor)
25 BuildRequires:  pkgconfig(dlog)
26 BuildRequires:  pkgconfig(libxml-2.0)
27 BuildRequires:  pkgconfig(tts)
28 BuildRequires:  pkgconfig(libscl-common)
29
30
31 %description
32 A library that helps developing S/W Keyboard
33
34 %package devel
35 Summary:    SCL header file
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38
39 %description devel
40 A devel package of libscl-ui library that helps developing S/W Keyboard
41
42 %prep
43 %setup -q
44
45
46 %build
47 rm -rf CMakeFiles
48 rm -rf CMakeCache.txt
49
50 %if "%{profile}" == "wearable"
51 CFLAGS+=" -D_WEARABLE";
52 CXXFLAGS+=" -D_WEARABLE";
53 %endif
54
55 %if "%{profile}" == "mobile"
56 CFLAGS+=" -D_MOBILE";
57 CXXFLAGS+=" -D_MOBILE";
58 %endif
59
60 %if "%{profile}" == "tv"
61 CFLAGS+=" -D_TV";
62 CXXFLAGS+=" -D_TV";
63 %endif
64
65 %if %{with wayland}
66 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
67 %else
68 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
69 %endif
70 make %{?jobs:-j%jobs}
71
72 %install
73 rm -rf %{buildroot}
74 mkdir -p %{buildroot}/usr/share/license
75 cp LICENSE %{buildroot}/usr/share/license/%{name}
76
77 %make_install
78
79
80
81 %post
82
83 %postun
84
85 %files
86 %manifest %{name}.manifest
87 %defattr(-,root,root,-)
88 %{_libdir}/libscl-ui.so
89 %{_datadir}/libscl-ui/metadata.xml
90 /usr/share/license/%{name}
91
92 %files devel
93 %defattr(-,root,root,-)
94 %{_includedir}/*
95 %{_libdir}/pkgconfig/libscl-ui.pc
96 %{_bindir}/xml2binary