Update package version to 0.6.10
[platform/core/uifw/libscl-ui.git] / packaging / libscl-ui.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %define _optdir /opt
5 %define _appdir %{_optdir}/apps
6
7 Name:       libscl-ui
8 Summary:    A library for developing XML-based software keyboards
9 Version:    0.6.10
10 Release:    1
11 Group:      Graphics & UI Framework/Input
12 License:    Apache-2.0
13 Source0:    libscl-ui-%{version}.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(elementary)
17 %if %{with wayland}
18 %else
19 BuildRequires:  pkgconfig(x11)
20 %endif
21 BuildRequires:  pkgconfig(vconf)
22 BuildRequires:  pkgconfig(feedback)
23 BuildRequires:  pkgconfig(dlog)
24 BuildRequires:  pkgconfig(libxml-2.0)
25 BuildRequires:  pkgconfig(tts)
26 BuildRequires:  pkgconfig(libscl-common)
27
28
29 %description
30 A library that helps developing S/W Keyboard
31
32 %package devel
33 Summary:    SCL header file
34 Group:      Development/Libraries
35 Requires:   %{name} = %{version}-%{release}
36
37 %description devel
38 A devel package of libscl-ui library that helps developing S/W Keyboard
39
40 %prep
41 %setup -q
42
43
44 %build
45 rm -rf CMakeFiles
46 rm -rf CMakeCache.txt
47
48 %if "%{profile}" == "wearable"
49 CFLAGS+=" -D_WEARABLE";
50 CXXFLAGS+=" -D_WEARABLE";
51 %endif
52
53 %if "%{profile}" == "mobile"
54 CFLAGS+=" -D_MOBILE";
55 CXXFLAGS+=" -D_MOBILE";
56 %endif
57
58 %if "%{profile}" == "tv"
59 CFLAGS+=" -D_TV";
60 CXXFLAGS+=" -D_TV";
61 %endif
62
63 %if %{with wayland}
64 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
65 %else
66 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
67 %endif
68 make %{?jobs:-j%jobs}
69
70 %install
71 rm -rf %{buildroot}
72 mkdir -p %{buildroot}/usr/share/license
73 cp LICENSE %{buildroot}/usr/share/license/%{name}
74
75 %make_install
76
77
78
79 %post
80
81 %postun
82
83 %files
84 %manifest %{name}.manifest
85 %defattr(-,root,root,-)
86 %{_libdir}/libscl-ui.so
87 %{_datadir}/libscl-ui/metadata.xml
88 /usr/share/license/%{name}
89
90 %files devel
91 %defattr(-,root,root,-)
92 %{_includedir}/*
93 %{_libdir}/pkgconfig/libscl-ui.pc
94 %{_bindir}/xml2binary