e3823455adcfb8c02ac055aed97061ce2e0a703f
[platform/core/uifw/libscl-ui.git] / packaging / libscl-ui.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       libscl-ui
5 Summary:    A library for developing XML-based software keyboards
6 Version:    0.6.43
7 Release:    1
8 Group:      Graphics & UI Framework/Input
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(elementary)
13 %if %{with wayland}
14 %else
15 BuildRequires:  pkgconfig(ecore-x)
16 BuildRequires:  pkgconfig(x11)
17 %endif
18 BuildRequires:  pkgconfig(vconf)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  pkgconfig(feedback)
21 BuildRequires:  pkgconfig(dlog)
22 BuildRequires:  pkgconfig(libxml-2.0)
23 BuildRequires:  pkgconfig(tts)
24 BuildRequires:  pkgconfig(libscl-common)
25
26
27 %description
28 A library that helps developing S/W Keyboard
29
30 %package devel
31 Summary:    SCL-UI header file
32 Group:      Development/Libraries
33 Requires:   %{name} = %{version}-%{release}
34
35 %description devel
36 A devel package of libscl-ui library that helps developing S/W Keyboard
37
38 %prep
39 %setup -q
40
41
42 %build
43 rm -rf CMakeFiles
44 rm -rf CMakeCache.txt
45
46 %if %{with wayland}
47 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
48 %else
49 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
50 %endif
51 make %{?_smp_mflags}
52
53 %install
54 rm -rf %{buildroot}
55
56 %make_install
57
58
59
60 %post -p /sbin/ldconfig
61
62 %postun -p /sbin/ldconfig
63
64 %files
65 %manifest %{name}.manifest
66 %defattr(-,root,root,-)
67 %{_libdir}/%{name}.so
68 %{_datadir}/%{name}/metadata.xml
69 %license LICENSE
70
71 %files devel
72 %defattr(-,root,root,-)
73 %{_includedir}/*
74 %{_libdir}/pkgconfig/%{name}.pc
75 %{_bindir}/xml2binary