b802874b37fa55b2d188892e1f49a304e61f518d
[platform/core/uifw/libscl-ui-nui.git] / packaging / libscl-ui-nui.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       libscl-ui-nui
5 Summary:    A library for developing XML-based software keyboards
6 Version:    0.6.91
7 Release:    1
8 Group:      Graphics & UI Framework/Input
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(elementary)
13 BuildRequires:  pkgconfig(eldbus)
14 BuildRequires:  pkgconfig(ecore-wl2)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(feedback)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(libxml-2.0)
20 BuildRequires:  pkgconfig(tts)
21 BuildRequires:  pkgconfig(libscl-common)
22 BuildRequires:  pkgconfig(dbus-1)
23 BuildRequires:  pkgconfig(gio-2.0)
24 BuildRequires:  pkgconfig(capi-ui-inputmethod)
25
26 %description
27 A library that helps developing S/W Keyboard
28
29 %package devel
30 Summary:    SCL-UI-NUI header file
31 Group:      Development/Libraries
32 Requires:   %{name} = %{version}-%{release}
33
34 %description devel
35 A devel package of libscl-ui-nui library that helps developing S/W Keyboard
36
37 %prep
38 %setup -q
39
40
41 %build
42 export CFLAGS+=" -fvisibility=hidden -DTIZEN_DEBUG_ENABLE -Werror"
43 export CXXFLAGS+=" -fvisibility=hidden -fvisibility-inlines-hidden -DTIZEN_DEBUG_ENABLE -Werror"
44 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
45
46 # The -fvisibility=hidden option disables a generation of the rtti information for
47 # some classes with hidden visibility, this information is critically needed for
48 # ubsan VPTR check. Since this library needed to ise-default package, we should
49 # just disable visibility option with ubsan to avoid situation with undefined
50 # refernce to typeinfo.
51 %{?ubsan:
52 export CFLAGS=$(echo $CFLAGS | sed -e "s/-fvisibility=hidden//g")
53 export CXXFLAGS=$(echo $CXXFLAGS | sed -e "s/-fvisibility=hidden//g" -e "s/-fvisibility-inlines-hidden//g")
54 }
55
56 rm -rf CMakeFiles
57 rm -rf CMakeCache.txt
58 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
59
60 %cmake . -Dwith_wayland=TRUE -DMAJORVER=${MAJORVER} -DFULLVER=%{version}
61
62 make %{?_smp_mflags}
63
64 %install
65 rm -rf %{buildroot}
66
67 %make_install
68
69
70
71 %post -p /sbin/ldconfig
72
73 %postun -p /sbin/ldconfig
74
75 %files
76 %manifest %{name}.manifest
77 %defattr(-,root,root,-)
78 %{_libdir}/*.so
79 %{_libdir}/*.so.*
80 %license LICENSE
81
82 %files devel
83 %defattr(-,root,root,-)
84 %{_includedir}/*
85 %{_libdir}/pkgconfig/*.pc