Update package version to 0.4.14
[platform/core/uifw/libscl-core.git] / packaging / libscl-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %define _optdir /opt
5 %define _appdir %{_optdir}/apps
6
7 Name:       libscl-core
8 Summary:    A library for developing software keyboards
9 Version:    0.4.14
10 Release:    1
11 Group:      Graphics & UI Framework/Input
12 License:    Apache-2.0
13 Source0:    libscl-core-%{version}.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(elementary)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(isf)
20 %if %{with wayland}
21 BuildRequires:  pkgconfig(ecore-wayland)
22 BuildRequires:  pkgconfig(wayland-client)
23 BuildRequires:  pkgconfig(input-method-client)
24 %else
25 BuildRequires:  pkgconfig(ecore-x)
26 BuildRequires:  pkgconfig(x11)
27 %endif
28 BuildRequires:  pkgconfig(libscl-common)
29 BuildRequires:  pkgconfig(capi-appfw-application)
30
31
32 %description
33 A library that helps developing S/W Keyboard
34
35 %package devel
36 Summary:    SCL-Core header file
37 Group:      Development/Libraries
38 Requires:   %{name} = %{version}-%{release}
39
40 %description devel
41 A devel package of libscl-core library that helps developing S/W Keyboard
42
43 %prep
44 %setup -q
45
46
47 %build
48 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
49 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
50 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
51
52 rm -rf CMakeFiles
53 rm -rf CMakeCache.txt
54
55 %if %{with wayland}
56 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
57 %else
58 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
59 %endif
60 make %{?jobs:-j%jobs}
61
62 %install
63 rm -rf %{buildroot}
64 mkdir -p %{buildroot}/usr/share/license
65 cp LICENSE %{buildroot}/usr/share/license/%{name}
66
67 %make_install
68
69
70
71 %post
72
73 %postun
74
75 %files
76 %manifest %{name}.manifest
77 %defattr(-,root,root,-)
78 %{_libdir}/libscl-core.so
79 /usr/share/license/%{name}
80
81 %files devel
82 %defattr(-,root,root,-)
83 %{_includedir}/*
84 %{_libdir}/pkgconfig/libscl-core.pc