Update package version to 0.4.39
[platform/core/uifw/libscl-core.git] / packaging / libscl-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %if "%{?profile}" == "wearable"
5 %define WITH_WEBSOCKET TRUE
6 %else
7 %define WITH_WEBSOCKET FALSE
8 %endif
9
10 Name:       libscl-core
11 Summary:    A library for developing software keyboards
12 Version:    0.4.39
13 Release:    1
14 Group:      Graphics & UI Framework/Input
15 License:    Apache-2.0
16 Source0:    %{name}-%{version}.tar.gz
17 BuildRequires:  cmake
18 BuildRequires:  pkgconfig(elementary)
19 BuildRequires:  pkgconfig(vconf)
20 BuildRequires:  pkgconfig(dlog)
21 BuildRequires:  pkgconfig(isf)
22 %if %{with wayland}
23 BuildRequires:  pkgconfig(ecore-wayland)
24 BuildRequires:  pkgconfig(wayland-client)
25 BuildRequires:  pkgconfig(input-method-client)
26 %else
27 BuildRequires:  pkgconfig(ecore-x)
28 BuildRequires:  pkgconfig(x11)
29 %endif
30 BuildRequires:  pkgconfig(libscl-common)
31 BuildRequires:  pkgconfig(appcore-efl)
32 BuildRequires:  pkgconfig(capi-appfw-application)
33 %if "%{WITH_WEBSOCKET}" == "TRUE"
34 BuildRequires:  pkgconfig(libwebsockets)
35 %endif
36
37
38 %description
39 A library that helps developing S/W Keyboard
40
41 %package devel
42 Summary:    SCL-Core header file
43 Group:      Development/Libraries
44 Requires:   %{name} = %{version}-%{release}
45
46 %description devel
47 A devel package of libscl-core library that helps developing S/W Keyboard
48
49 %prep
50 %setup -q
51
52
53 %build
54 export CFLAGS+=" -fvisibility=hidden -DTIZEN_DEBUG_ENABLE -Werror"
55 export CXXFLAGS+="  -fvisibility=hidden -fvisibility-inlines-hidden -DTIZEN_DEBUG_ENABLE -Werror"
56 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
57
58 rm -rf CMakeFiles
59 rm -rf CMakeCache.txt
60
61 %if %{with wayland}
62 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE -Dwith_websocket=%{WITH_WEBSOCKET}
63 %else
64 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_websocket=%{WITH_WEBSOCKET}
65 %endif
66 make %{?_smp_mflags}
67
68 %install
69 rm -rf %{buildroot}
70
71 %make_install
72
73
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %files
80 %manifest %{name}.manifest
81 %defattr(-,root,root,-)
82 %{_libdir}/%{name}.so
83 %license LICENSE
84
85 %files devel
86 %defattr(-,root,root,-)
87 %{_includedir}/*
88 %{_libdir}/pkgconfig/%{name}.pc