Update package version to 0.4.3
[platform/core/uifw/libscl-core.git] / packaging / libscl-core.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %define _optdir /opt
5 %define _appdir %{_optdir}/apps
6
7 Name:       libscl-core
8 Summary:    A library for developing software keyboards
9 Version:    0.4.3
10 Release:    1
11 Group:      Graphics & UI Framework/Input
12 License:    Apache-2.0
13 Source0:    libscl-core-%{version}.tar.gz
14 BuildRequires:  gettext-tools
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(elementary)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(isf)
20 %if %{with wayland}
21 BuildRequires:  pkgconfig(ecore-wayland)
22 BuildRequires:  pkgconfig(wayland-client)
23 BuildRequires:  pkgconfig(input-method-client)
24 %else
25 BuildRequires:  pkgconfig(ecore-x)
26 BuildRequires:  pkgconfig(x11)
27 %endif
28 BuildRequires:  pkgconfig(libscl-common)
29
30
31 %description
32 A library that helps developing S/W Keyboard
33
34 %package devel
35 Summary:    SCL-Core header file
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38
39 %description devel
40 A devel package of libscl-core library that helps developing S/W Keyboard
41
42 %prep
43 %setup -q
44
45
46 %build
47 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE"
48 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE"
49 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
50
51 rm -rf CMakeFiles
52 rm -rf CMakeCache.txt
53
54 %if %{with wayland}
55 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
56 %else
57 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
58 %endif
59 make %{?jobs:-j%jobs}
60
61 %install
62 rm -rf %{buildroot}
63 mkdir -p %{buildroot}/usr/share/license
64 cp LICENSE %{buildroot}/usr/share/license/%{name}
65
66 %make_install
67
68
69
70 %post
71
72 %postun
73
74 %files
75 %manifest %{name}.manifest
76 %defattr(-,root,root,-)
77 %{_libdir}/libscl-core.so
78 /usr/share/license/%{name}
79
80 %files devel
81 %defattr(-,root,root,-)
82 %{_includedir}/*
83 %{_libdir}/pkgconfig/libscl-core.pc