Use %license to create license file
[platform/core/uifw/libscl-common.git] / packaging / libscl-common.spec
1 Name:       libscl-common
2 Summary:    A library for developing software keyboards
3 Version:    0.4.1
4 Release:    1
5 Group:      Graphics & UI Framework/Input
6 License:    Apache-2.0
7 Source0:    libscl-common-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(evas)
10
11
12 %description
13 A library that helps developing S/W Keyboard
14
15 %package devel
16 Summary:    SCL-Common header file
17 Group:      Development/Libraries
18 Requires:   %{name} = %{version}-%{release}
19
20 %description devel
21 A devel package of libscl-common library that helps developing S/W Keyboard
22
23 %prep
24 %setup -q
25
26
27 %build
28 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33
34 %make_install
35
36
37
38 %post
39
40 %postun
41
42 %files
43 %manifest %{name}.manifest
44 %defattr(-,root,root,-)
45 %{_libdir}/libscl-common.so
46 %license LICENSE
47
48 %files devel
49 %defattr(-,root,root,-)
50 %{_includedir}/*
51 %{_libdir}/pkgconfig/libscl-common.pc