resetting manifest requested domain to floor
[platform/core/appfw/librua.git] / packaging / librua.spec
1 Name:           librua
2 Version:        0.1.0
3 Release:        34
4 License:        Apache-2.0
5 Summary:        Recently used application
6 Group:          Application Framework/Libraries
7 Source0:        librua-%{version}.tar.gz
8 Source1001:     librua.manifest
9 BuildRequires:  cmake
10 BuildRequires:  sqlite3
11 BuildRequires:  pkgconfig(db-util)
12 BuildRequires:  pkgconfig(sqlite3)
13
14 %description
15 Recently used application library
16
17 %package devel
18 Summary:        Recently used application (devel)
19 Requires:       %{name} = %{version}
20
21 %description devel
22 Recently used application library (devel)
23
24 %prep
25 %setup -q
26 cp %{SOURCE1001} .
27
28 %build
29 %cmake .
30 make %{?_smp_mflags}
31
32 %install
33 %make_install
34 mkdir -p %{buildroot}/opt/dbspace
35 sqlite3 %{buildroot}/opt/dbspace/.rua.db < data/rua_db.sql
36
37 %post -p /sbin/ldconfig
38
39 %postun -p /sbin/ldconfig
40
41 %files
42 %manifest %{name}.manifest
43 %defattr(-,root,root,-)
44 %config(noreplace) %attr(0660,root,app) /opt/dbspace/.rua.db*
45 %{_libdir}/librua.so.*
46 %license LICENSE
47
48 %files devel
49 %manifest %{name}.manifest
50 %defattr(-,root,root,-)
51 %dir %{_includedir}/rua
52 %{_includedir}/rua/*.h
53 %{_libdir}/librua.so
54 %{_libdir}/pkgconfig/rua.pc
55