Revert "Package version up to 0.13.3"
[platform/upstream/libpciaccess.git] / packaging / libpciaccess.spec
1 %bcond_with x
2
3 Name:           libpciaccess
4 Version:        0.13.2
5 Release:        0
6 License:        MIT
7 Summary:        PCI access library
8 Url:            http://cgit.freedesktop.org/xorg/lib/libpciaccess/
9 Group:          Base/Device Management
10 Source:         %{name}-%{version}.tar.bz2
11 Source1001:     libpciaccess.manifest
12
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  pkgconfig
17 BuildRequires:  pkgconfig(zlib)
18 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
19
20 %description
21 libpciaccess is a library for portable PCI access routines across multiple
22 operating systems.
23
24 %package devel
25 Summary:        PCI access library development package
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28 Requires:       pkgconfig
29
30 %description devel
31 libpciaccess is a library for portable PCI access routines across multiple
32 operating systems.
33
34 This package contains development files needed to develop with the
35 libpciaccess library.
36
37
38 %prep
39 %setup -q
40 cp %{SOURCE1001} .
41 %build
42 NOCONFIGURE=1
43 %autogen
44 export CFLAGS="$CFLAGS -w"
45 export CFLAGS="-O2 -g2 -pipe -w -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong -fmessage-length=0 -Wl,--as-needed -Wl,-z,relro"
46 %configure --disable-static \
47            --with-pciids-path=%{_datadir}/misc --with-zlib
48 make %{?_smp_mflags}
49
50 %install
51 rm -rf %{buildroot}
52 %make_install
53
54 %remove_docs
55
56 %post -p /sbin/ldconfig
57
58 %postun -p /sbin/ldconfig
59
60 %files
61 %manifest %{name}.manifest
62 %defattr(-,root,root,-)
63 %{_libdir}/libpciaccess.so.*
64 %license COPYING
65
66 %files devel
67 %manifest %{name}.manifest
68 %defattr(-,root,root,-)
69 %{_includedir}/pciaccess.h
70 %{_libdir}/libpciaccess.so
71 %{_libdir}/pkgconfig/pciaccess.pc
72 %license COPYING
73