Enabling omxil for TW1
[platform/adaptation/ap_samsung/libomxil-e3250-v4l2.git] / packaging / libomxil-e3250-v4l2.spec
1 Name: libomxil-e3250-v4l2
2 Summary: OpenMAX IL for e3250-v4l2
3 Version: 0.1.0
4 License: TO BE FILLED IN
5 Group: Development/Libraries
6 Release: 0
7 ExclusiveArch: %arm
8 Source: %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 #!BuildIgnore: kernel-headers
12 BuildConflicts: linux-glibc-devel
13 BuildRequires: kernel-headers-tizen-dev
14 BuildRequires: pkgconfig(dlog)
15 BuildRequires: pkgconfig(mm-common)
16
17 %description
18 implementation of OpenMAX IL for e3250-v4l2 for B2
19
20
21 %package devel
22 Summary: OpenMAX IL for e3250-v4l2 (Developement)
23 Group: Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25
26 %description devel
27 development package for libomxil-e3250-v4l2
28
29 %prep
30 %setup -q
31
32 %build
33 ./autogen.sh
34
35 export CFLAGS+="\
36 %ifnarch aarch64
37  -mfpu=neon\
38  -DUSE_NEON\
39 %endif
40  -DUSE_PB\
41  -DUSE_DMA_BUF\
42  -DUSE_H264_PREPEND_SPS_PPS\
43  -DGST_EXT_TIME_ANALYSIS"
44
45 %ifnarch aarch64
46 %configure --prefix=%{_prefix} --disable-static --enable-dlog --enable-exynos3250 --enable-neon
47 %else
48 %configure --prefix=%{_prefix} --disable-static --enable-dlog --enable-exynos3250 --disable-neon
49 %endif
50
51 #make %{?jobs:-j%jobs}
52 make
53
54
55 %install
56 rm -rf %{buildroot}
57 #mkdir -p %{buildroot}/usr/share/license
58 #cp COPYING %{buildroot}/usr/share/license/%{name}
59 %make_install
60
61
62 %post -p /sbin/ldconfig
63
64 %postun -p /sbin/ldconfig
65
66
67 %files
68 %manifest libomxil-e3250-v4l2.manifest
69 %{_libdir}/*.so*
70 %{_libdir}/omx/*.so
71
72
73 %files devel
74 /usr/include/*
75 %{_libdir}/pkgconfig/*
76