remove dep for doxygen
[profile/ivi/ofono-qt.git] / packaging / libofono-qt.spec
1 Name:       libofono-qt
2 Summary:    Qt bindings for oFono
3 Version:    1.5
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2.1
7 Source0:    %{name}-%{version}.tar.bz2
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(QtCore)
11 BuildRequires:  pkgconfig(QtDBus)
12
13 %description
14 This package contains the Qt bindings for a number of oFono cellular service
15 interfaces.
16
17 %package devel
18 Summary:    Development files for the oFono Qt bindings
19 Group:      Development/Libraries
20 Requires:   %{name} = %{version}-%{release}
21 Requires:   %{name} = %{version}
22
23 %description devel
24 This package contains the development header files for the oFono Qt bindings.
25
26 %prep
27 %setup -q -n %{name}-%{version}
28
29 %build
30
31 export QTDIR=/usr/share/qt5
32
33 qmake install_prefix=/usr
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38
39 make INSTALL_ROOT=%{buildroot} install
40
41 %post -p /sbin/ldconfig
42
43 %postun -p /sbin/ldconfig
44
45 %files
46 %defattr(-,root,root,-)
47 %{_libdir}/*.so.*
48
49 %files devel
50 %defattr(-,root,root,-)
51 %{_libdir}/*.prl
52 %{_libdir}/*.so
53 %{_libdir}/pkgconfig/*.pc
54 %{_includedir}/ofono-qt/*.h
55 %{_datadir}/qt4/mkspecs/features/*.prf
56 %{_libdir}/libofono-qt/tests/*