Add wrapper to send event callback
[platform/core/connectivity/libnet-client.git] / packaging / libnet-client.spec
1 Name:           libnet-client
2 Summary:        Network Client library (Shared library)
3 Version:        1.2.4
4 Release:        1
5 Group:          System/Network
6 License:        Flora-1.1
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(vconf)
10 BuildRequires:  pkgconfig(gio-2.0)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gthread-2.0)
13
14 %if 0%{?gtests:1}
15 BuildRequires:  pkgconfig(gmock)
16 %endif
17
18 %description
19 Network Client library (Shared library)
20
21 %package devel
22 Summary:        Network Client library (Development)
23 Group:          Development/Library
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 Network Client library (Development)
28
29 %prep
30 %setup -q
31
32
33 %build
34 %if 0%{?model_build_feature_network_dsds} == 1
35 export DUALSIM_CFLAGS+=" -DTIZEN_DUALSIM_ENABLE"
36 %endif
37
38 %if 0%{?gtests:1}
39 export GTEST_CFLAGS+=" -DGTEST_ENABLED"
40 %endif
41
42 ./autogen.sh
43 ./configure --prefix=/usr --libdir=%{_libdir} --enable-gcov=%{?gcov:yes}%{!?gcov:no}
44
45 make %{?_smp_mflags}
46
47
48 %if 0%{?gtests:1}
49 cd gtest
50 make
51 cd ..
52 %endif
53
54
55 %install
56 %make_install
57
58 %if 0%{?gtests:1}
59 cd gtest
60 mkdir -p %{buildroot}/%{_bindir}
61 install -m 0755 gtest-%{name} %{buildroot}/%{_bindir}/gtest-%{name}
62 cd ..
63 %endif
64
65 cd test
66 cp -rf %{buildroot}%{_libdir}/ ./
67 ./build.sh
68 cd ..
69
70 %files
71 %manifest libnet-client.manifest
72 %{_libdir}/*.so.*
73 %license LICENSE
74 %if 0%{?gtests:1}
75 %{_bindir}/gtest-%{name}
76 %endif
77
78 %files devel
79 %defattr(-,root,root,-)
80 %{_includedir}/network/*.h
81 %{_libdir}/*.so
82 %{_libdir}/pkgconfig/network.pc