Add some types for cellular pdn
[platform/core/connectivity/libnet-client.git] / packaging / libnet-client.spec
1 Name:           libnet-client
2 Summary:        Network Client library (Shared library)
3 Version:        1.1.50
4 Release:        1
5 Group:          System/Network
6 License:        Flora-1.1
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(dlog)
9 BuildRequires:  pkgconfig(vconf)
10 BuildRequires:  pkgconfig(gio-2.0)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(gthread-2.0)
13
14 %description
15 Network Client library (Shared library)
16
17 %package devel
18 Summary:        Network Client library (Development)
19 Group:          Development/Library
20 Requires:       %{name} = %{version}-%{release}
21
22 %description devel
23 Network Client library (Development)
24
25 %prep
26 %setup -q
27
28
29 %build
30 %if 0%{?model_build_feature_network_dsds} == 1
31 export DUALSIM_CFLAGS+=" -DTIZEN_DUALSIM_ENABLE"
32 %endif
33
34 %if "%{profile}" == "wearable"
35 export WEARABLE_CFLAGS+=" -DTIZEN_WEARABLE"
36 %endif
37
38 %if "%{profile}" == "tv"
39         export TIZEN_TV_CFLAGS+=" -DTIZEN_TV"
40 %endif
41
42 ./autogen.sh
43 ./configure --prefix=/usr --libdir=%{_libdir}
44
45 make %{?_smp_mflags}
46
47
48 %install
49 %make_install
50
51 #License
52 mkdir -p %{buildroot}%{_datadir}/license
53 cp LICENSE %{buildroot}%{_datadir}/license/libnet-client
54
55 cd test
56 cp -rf %{buildroot}%{_libdir}/ ./
57 ./build.sh
58 cd ..
59
60 %files
61 %manifest libnet-client.manifest
62 %{_libdir}/libnetwork.so
63 %{_libdir}/libnetwork.so.0
64 %attr(644,-,-) %{_libdir}/libnetwork.so.0.0.0
65 %{_datadir}/license/libnet-client
66
67 %files devel
68 %{_includedir}/network/*.h
69 %{_libdir}/pkgconfig/network.pc