focus-server: fix bug of invoking monitor callback of other nodes
[platform/core/multimedia/libmm-sound.git] / packaging / libmm-sound.spec
1 Name:       libmm-sound
2 Summary:    MMSound Package contains client lib and sound_server binary
3 Version:    0.11.17
4 Release:    0
5 Group:      System/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source3:    sound-server.conf
9 Source4:    focus-server.service
10 Source5:    focus-server.path
11 Source6:    focus-server.conf
12 Requires: security-config
13 %if "%{?TIZEN_PRODUCT_TV}" == "1"
14 Source7:    libmm-sound.notstrip
15 Source8:    focus-server-tv.service
16 %endif
17 Source9:    org.tizen.SoundServer.service
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
20 BuildRequires: pkgconfig(mm-common)
21 BuildRequires: pkgconfig(mm-log)
22 BuildRequires: pkgconfig(mm-session)
23 BuildRequires: pkgconfig(glib-2.0)
24 BuildRequires: pkgconfig(gio-2.0)
25 BuildRequires: pkgconfig(vconf)
26 BuildRequires: pkgconfig(libpulse)
27 BuildRequires: pkgconfig(sndfile)
28 %if "%{?TIZEN_PRODUCT_TV}" == "1"
29 BuildRequires: pkgconfig(lwipc)
30 %endif
31 %ifarch %{arm}
32 %endif
33
34 %description
35 MMSound Package contains client lib and sound_server binary for sound system
36
37
38 %package devel
39 Summary: MMSound development package
40 Group:      Development/Libraries
41 Requires:   %{name} = %{version}-%{release}
42
43 %description devel
44 MMSound development package for sound system
45
46 %package sdk-devel
47 Summary: MMSound development package
48 Group:      Development/Libraries
49 Requires:   %{name}-devel = %{version}-%{release}
50
51 %description sdk-devel
52 MMSound development package for sound system
53
54 %package tool
55 Summary: MMSound utility package - contians mm_sound_testsuite, sound_check
56 Group:      TO_BE/FILLED_IN
57 Requires:   %{name} = %{version}-%{release}
58
59 %description tool
60 MMSound utility package - contians mm_sound_testsuite, sound_check for sound system
61
62 %prep
63 %setup -q
64
65 %build
66
67 CFLAGS="%{optflags} -fvisibility=hidden -D_TIZEN_PUBLIC_ -DMM_DEBUG_FLAG -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\"" ;export CFLAGS
68
69 %if "%{?TIZEN_PRODUCT_TV}" == "1"
70         CFLAGS+=" -DTIZEN_TV";export CFLAGS
71 %endif
72
73 ./autogen.sh
74 %configure \
75        --with-plugindir=%{_libdir}/soundplugins \
76 %if "%{?TIZEN_PRODUCT_TV}" == "1"
77        --enable-prelink \
78        --enable-lwipc \
79 %endif
80         --prefix=/usr --enable-pulse --enable-focus
81
82 make %{?_smp_mflags}
83
84 %install
85 rm -rf %{buildroot}
86 mkdir -p %{buildroot}/etc/dbus-1/system.d/
87 cp %{SOURCE3} %{buildroot}/etc/dbus-1/system.d/sound-server.conf
88 cp %{SOURCE6} %{buildroot}/etc/dbus-1/system.d/focus-server.conf
89 %if "%{?TIZEN_PRODUCT_TV}" == "1"
90 cp %{SOURCE8} %{SOURCE4}
91 %endif
92 mkdir -p %{buildroot}/usr/share/dbus-1/system-services/
93 cp %{SOURCE9} %{buildroot}/usr/share/dbus-1/system-services/org.tizen.SoundServer.service
94
95 %make_install
96 %if "%{?TIZEN_PRODUCT_TV}" == "1"
97 mkdir -p %{buildroot}%{_sysconfdir}/notstrip
98 install -m0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/notstrip/libmm-sound.notstrip
99 install -d %{buildroot}%{_unitdir}/sysinit.target.wants
100 %else
101 install -d %{buildroot}%{_unitdir}/multi-user.target.wants
102 %endif
103 install -m0644 %{SOURCE4} %{buildroot}%{_unitdir}/
104 install -m0644 %{SOURCE5} %{buildroot}%{_unitdir}/
105 %if "%{?TIZEN_PRODUCT_TV}" == "1"
106 ln -sf ../focus-server.path %{buildroot}%{_unitdir}/sysinit.target.wants/focus-server.path
107 %else
108 ln -sf ../focus-server.path %{buildroot}%{_unitdir}/multi-user.target.wants/focus-server.path
109 %endif
110 %post
111 /sbin/ldconfig
112
113 %postun -p /sbin/ldconfig
114
115
116 %files
117 %manifest libmm-sound.manifest
118 %defattr(-,root,root,-)
119 %{_bindir}/focus_server
120 %{_bindir}/sound_server
121 %{_libdir}/libmmfsound.so.*
122 %{_libdir}/libmmfsoundcommon.so.*
123 %{_libdir}/libmmfkeysound.so.*
124 %{_libdir}/libmmfbootsound.so.*
125 %{_libdir}/soundplugins/libsoundplugintone.so
126 %{_libdir}/soundplugins/libsoundpluginwave.so
127 %if 0%{?tizen_audio_feature_ogg_enable}
128 %{_libdir}/soundplugins/libsoundplugintremoloogg.so
129 %endif
130 %if "%{?TIZEN_PRODUCT_TV}" == "1"
131 %{_sysconfdir}/notstrip/libmm-sound.notstrip
132 %{_unitdir}/sysinit.target.wants/focus-server.path
133 %else
134 %{_unitdir}/multi-user.target.wants/focus-server.path
135 %endif
136 %{_unitdir}/focus-server.service
137 %{_unitdir}/focus-server.path
138 /usr/share/sounds/sound-server/*
139 %license LICENSE.APLv2
140 /etc/dbus-1/system.d/sound-server.conf
141 /etc/dbus-1/system.d/focus-server.conf
142 %{_datadir}/dbus-1/system-services/org.tizen.SoundServer.service
143
144 %files devel
145 %defattr(-,root,root,-)
146 %{_libdir}/libmmfkeysound.so
147 %{_libdir}/libmmfbootsound.so
148 %{_libdir}/libmmfsound.so
149 %{_libdir}/libmmfsoundcommon.so
150 %{_includedir}/mmf/mm_sound_private.h
151 %exclude %{_includedir}/mmf/mm_sound_pa_client.h
152
153 %files sdk-devel
154 %defattr(-,root,root,-)
155 %{_includedir}/mmf/mm_sound.h
156 %{_includedir}/mmf/mm_sound_focus.h
157 %{_includedir}/mmf/mm_sound_device.h
158 %exclude %{_includedir}/mmf/mm_sound_focus_socket.h
159 %exclude %{_includedir}/mmf/mm_sound_pa_client.h
160 %{_libdir}/pkgconfig/mm-keysound.pc
161 %{_libdir}/pkgconfig/mm-bootsound.pc
162 %{_libdir}/pkgconfig/mm-sound.pc
163
164 %files tool
165 %manifest libmm-sound-tool.manifest
166 %defattr(-,root,root,-)
167 %{_bindir}/mm_sound_testsuite
168 %license LICENSE.APLv2