Update recommend format when default format is not supported
[platform/core/multimedia/libmm-camcorder.git] / packaging / libmm-camcorder.spec
1 Name:       libmm-camcorder
2 Summary:    Camera and recorder library
3 Version:    1.2.6
4 Release:    0
5 Group:      Multimedia/Libraries
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(glib-2.0)
11 BuildRequires:  pkgconfig(gio-2.0)
12 BuildRequires:  pkgconfig(capi-system-info)
13 BuildRequires:  pkgconfig(mm-common)
14 BuildRequires:  pkgconfig(libexif)
15 BuildRequires:  pkgconfig(mmutil-imgp)
16 BuildRequires:  pkgconfig(mmutil-jpeg)
17 BuildRequires:  pkgconfig(gstreamer-1.0)
18 BuildRequires:  pkgconfig(gstreamer-base-1.0)
19 BuildRequires:  pkgconfig(gstreamer-allocators-1.0)
20 BuildRequires:  pkgconfig(gstreamer-video-1.0)
21 BuildRequires:  pkgconfig(gstreamer-app-1.0)
22 BuildRequires:  pkgconfig(vconf)
23 BuildRequires:  pkgconfig(libtbm)
24 BuildRequires:  pkgconfig(storage)
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(resource-center-api)
27 %if "%{tizen_profile_name}" == "tv"
28 BuildRequires:  pkgconfig(tv-resource-manager)
29 BuildRequires:  pkgconfig(tv-resource-information)
30 BuildRequires:  pkgconfig(capi-boost-tv)
31 %if (("%{_vd_cfg_product_type}" != "AUDIO") && ("%{_vd_cfg_target_repository}" != "emulator"))
32 BuildRequires:  pkgconfig(camera-conf-mgr-tv)
33 %endif
34 %else
35 BuildRequires:  pkgconfig(resource-manager)
36 BuildRequires:  pkgconfig(resource-information)
37 %endif
38 BuildRequires:  pkgconfig(ttrace)
39 BuildRequires:  pkgconfig(libtzplatform-config)
40 BuildRequires:  pkgconfig(dpm)
41 BuildRequires:  pkgconfig(dlog)
42 BuildRequires:  pkgconfig(hal-api-camera)
43 %if "%{gtests}" == "1"
44 BuildRequires:  pkgconfig(gmock)
45 %endif
46
47 %description
48 Camera and recorder function supported library.
49
50
51 %package devel
52 Summary:    Camera and recorder library for development
53 Group:      libdevel
54 Version:    %{version}
55 Requires:   %{name} = %{version}-%{release}
56
57 %description devel
58 Camera and recorder function supported library for development.
59
60
61 %prep
62 %setup -q
63
64
65 %build
66 %if 0%{?gcov:1}
67 export CFLAGS+=" -fprofile-arcs -ftest-coverage"
68 export LDFLAGS+=" -lgcov"
69 %endif
70 export CFLAGS+=" -D_LARGEFILE64_SOURCE -DGST_USE_UNSTABLE_API -DSYSCONFDIR=\\\"%{_hal_sysconfdir}\\\" -DTZ_SYS_ETC=\\\"%{TZ_SYS_ETC}\\\""
71 ./autogen.sh
72 %configure \
73 %if "%{tizen_profile_name}" == "tv"
74         --enable-rm \
75         --enable-product-tv \
76         --enable-boost \
77 %if (("%{_vd_cfg_product_type}" != "AUDIO") && ("%{_vd_cfg_target_repository}" != "emulator"))
78         --enable-camera-conf-mgr-tv \
79 %endif
80 %else
81         --enable-rm-common \
82 %endif
83 %if "%{gtests}" == "1"
84         --enable-gtests \
85 %endif
86         --disable-static
87 make %{?jobs:-j%jobs}
88
89 %install
90 %make_install
91
92
93 %post
94 /sbin/ldconfig
95
96 %postun -p /sbin/ldconfig
97
98 %files
99 %manifest libmm-camcorder.manifest
100 %license LICENSE.APLv2
101 %defattr(-,root,root,-)
102 %{_libdir}/*.so.*
103 %{_datadir}/sounds/mm-camcorder/*
104 %if "%{gtests}" == "1"
105 %{_bindir}/gtests-libmm-camcorder
106 %endif
107
108 %files devel
109 %defattr(-,root,root,-)
110 %{_includedir}/mmf/mm_camcorder.h
111 %{_libdir}/pkgconfig/mm-camcorder.pc
112 %{_libdir}/*.so