0d97a8d089ee3e0a5f79bf28371478140e7e96b7
[platform/core/location/liblocation-appman.git] / packaging / liblocation-appman.spec
1 %define _optdir /opt
2 Name:       liblocation-appman
3 Summary:    Location DB controler
4 Version:    0.1.6
5 Release:    1
6 Group:      System/Libraries
7 License:    TBD
8 Source0:    %{name}-%{version}.tar.gz
9 Source1001:     liblocation-appman.manifest
10
11 Requires(post): sqlite
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(sqlite3)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(capi-appfw-app-manager)
18 BuildRequires:  libgcrypt-devel
19
20 %description
21 Description: Location DB controller library
22
23
24 %package devel
25 Summary:    Location DB controller (Development files)
26 Group:      System/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 Description : Location DB controller Development Package
31
32
33 %prep
34 %setup -q -n %{name}-%{version}
35 cp %{SOURCE1001} .
36
37
38 %build
39 %cmake .
40
41 # Call make instruction with smp support
42 make %{?jobs:-j%jobs}
43
44 %post
45 /sbin/ldconfig
46
47 chown 0:5000 /opt/dbspace/.location-appman.db*
48 chmod 664 /opt/dbspace/.location-appman.db*
49 %postun -p /sbin/ldconfig
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54
55
56 %clean
57 rm -rf %{buildroot}
58
59 %files
60 %manifest %{name}.manifest
61 %defattr(-,root,root,-)
62 %{_libdir}/liblocation-appman.so*
63 %{_optdir}/dbspace/.location-appman.db*
64
65 %files devel
66 %manifest %{name}.manifest
67 %{_includedir}/location-appman/*.h
68 %{_libdir}/pkgconfig/*.pc