Export new APIs
[platform/framework/web/livebox.git] / packaging / liblivebox.spec
1 Name: liblivebox
2 Summary: Library for the development of a livebox 
3 Version: 0.6.3
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires: cmake, gettext-tools, coreutils
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(livebox-service)
12 BuildRequires: pkgconfig(provider)
13 BuildRequires: pkgconfig(ecore)
14 BuildRequires: pkgconfig(evas)
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(x11)
17
18 %description
19 Livebox development library
20
21 %package devel
22 Summary: Files for livebox development.
23 Group: Development/Libraries
24 Requires: %{name} = %{version}-%{release}
25
26 %description devel
27 Livebox development library (dev)
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33 %build
34 %if 0%{?sec_build_binary_debug_enable}
35 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
36 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
37 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
38 %endif
39
40 %if 0%{?tizen_build_binary_release_type_eng}
41 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
42 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
43 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
44 %endif
45
46 %cmake .
47 make %{?jobs:-j%jobs}
48
49 %install
50 rm -rf %{buildroot}
51 %make_install
52 mkdir -p %{buildroot}/%{_datarootdir}/license
53
54 %post
55
56 %files -n liblivebox
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %{_libdir}/*.so*
60 %{_datarootdir}/license/*
61
62 %files devel
63 %manifest %{name}.manifest
64 %defattr(-,root,root,-)
65 %{_includedir}/livebox/livebox.h
66 %{_libdir}/pkgconfig/*.pc
67
68 # End of a file