4 Summary: Livebox development library
9 Source0: %{name}-%{version}.tar.gz
10 Source1001: %{name}.manifest
11 BuildRequires: cmake, gettext-tools, coreutils
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(livebox-service)
14 BuildRequires: pkgconfig(provider)
15 BuildRequires: pkgconfig(ecore)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(elementary)
21 BuildRequires: pkgconfig(x11)
24 %if "%{sec_product_feature_livebox}" == "0"
29 Library for the development of a livebox
32 Summary: Livebox development library (dev)
33 Group: Development/Libraries
34 Requires: %{name} = %{version}-%{release}
37 Header & Package configuration files for livebox development
44 %if 0%{?sec_build_binary_debug_enable}
45 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
46 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
47 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
50 %if 0%{?tizen_build_binary_release_type_eng}
51 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
52 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
53 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
57 export WAYLAND_SUPPORT=On
58 export X11_SUPPORT=Off
60 export WAYLAND_SUPPORT=Off
64 %cmake . -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
70 mkdir -p %{buildroot}/%{_datarootdir}/license
72 %post -n liblivebox -p /sbin/ldconfig
73 %postun -n liblivebox -p /sbin/ldconfig
76 %manifest %{name}.manifest
77 %defattr(-,root,root,-)
79 %{_datarootdir}/license/*
82 %manifest %{name}.manifest
83 %defattr(-,root,root,-)
84 %{_includedir}/livebox/livebox.h
85 %{_libdir}/pkgconfig/*.pc