3aafd41754ba478d2e1c04274a231e7641b4ec6e
[apps/native/widget/widget.git] / packaging / liblivebox.spec
1 Name: liblivebox
2 Summary: Library for the development of a livebox 
3 Version: 0.2.2
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(livebox-service)
11 BuildRequires: pkgconfig(provider)
12 BuildRequires: pkgconfig(ecore)
13 BuildRequires: pkgconfig(evas)
14
15 %description
16 Livebox development library
17
18 %package devel
19 Summary: Files for livebox development.
20 Group: Development/Libraries
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24 Livebox development library (dev)
25
26 %prep
27 %setup -q
28
29 %build
30 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
31 make %{?jobs:-j%jobs}
32
33 %install
34 rm -rf %{buildroot}
35 %make_install
36 mkdir -p %{buildroot}/%{_datarootdir}/license
37
38 %post
39
40 %files -n liblivebox
41 %manifest liblivebox.manifest
42 %defattr(-,root,root,-)
43 %{_libdir}/*.so*
44 %{_datarootdir}/license/*
45
46 %files devel
47 %defattr(-,root,root,-)
48 %{_includedir}/livebox/livebox.h
49 %{_datarootdir}/doc/livebox/livebox_PG.h
50 %{_libdir}/pkgconfig/*.pc
51
52 # End of a file