41bc5a8c0538620ca8c2eeab904d27eaf36405ab
[platform/upstream/libiri.git] / packaging / libiri.spec
1 Name:       libiri
2 Version:    1.1
3 Release:    0
4 License:    BSD-3-Clause
5 Summary:    An IRI parsing library
6 Url:        http://code.google.com/p/libiri/
7 Group:      System/Libraries
8 Source:     %{name}-%{version}.tar.gz
9 Source1001: %{name}.manifest
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  libtool
13
14 %description
15 libiri is a simple toolkit for parsing Internationalized Resource Identifiers (IRIs).
16
17 For many intents and purposes, you can think of libiri as a “URL parser which supports Unicode”.
18
19 Specifically:
20
21 URLs are a subset of URIs
22 URIs are restricted to a portion of the ASCII character set
23 IRIs are a superset of URIs that are not restricted to ASCII characters
24 If something is a valid URL or URI, it's also a valid IRI.
25
26 %package devel
27 Summary:    An IRI parsing library - Development Files
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}
30
31 %description devel
32 libiri is a simple toolkit for parsing Internationalized Resource Identifiers (IRIs).
33
34 %prep
35 %setup -q
36 cp %{S:1001} .
37
38 %build
39 %reconfigure
40 make %{?_smp_mflags}
41
42 %install
43 %make_install
44
45
46 %files
47 %manifest %{name}.manifest
48 %license LICENSE
49 %{_libdir}/*.so
50
51
52 %files devel
53 %manifest %{name}.manifest
54 %{_libdir}/pkgconfig/*.pc
55 %{_includedir}/*.h
56 /usr/bin/iri-config