Code sync
[external/libijs.git] / packaging / libijs.spec
1 #
2 # spec file for package lcms (Version 1.19)
3 #
4 # Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18 # norootforbuild
19
20 Name:           libijs
21 License:        MIT License
22 Group:          System/Libraries
23 Summary:        IJS raster image transport protocol library
24 Version:        0.35
25 Release:        1
26 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
27 Source0:        %{name}-%{version}.tar.gz
28 #BuildRequires:  docbook, docbook-utils 
29
30 %description
31  IJS raster image transport protocol: shared library
32  IJS is, first and foremost, a protocol for transmission of raster page
33  images. This snapshot provides a reference implementation of the protocol,
34  the design of which is still in flux. When the protocol specification is
35  published, it will be authoritative. Applications should feel free to link
36  against the library provided in this package, adapt that code for their own
37  needs, or roll a completely new implementation.
38  .
39  IJS is a client-server protocol, used to write ghostscript drivers. The
40  drivers are separate programs. The client and server communicate via pipes,
41  though shared memory may be used additionally in the future. Currently IJS
42  is used by the hpijs and ijsgimpprint drivers.
43  .
44  Code for both the client- and server-side is included in the library. This
45  package provides the shared library.
46
47 %package devel
48 License:        MIT License
49 Summary:        Include Files and Libraries Mandatory for Development
50 Requires:       libijs eglibc-devel
51 Group:          Development/Libraries/C and C++
52
53 %description devel
54  IJS raster image transport protocol: development files
55  IJS (InkJet Server) is, first and foremost, a protocol for transmission of
56  raster page images. This snapshot provides a reference implementation of
57  the protocol, the design of which is still in flux. When the protocol
58  specification is published, it will be authoritative. Applications should
59  feel free to link against the library provided in this package, adapt that
60  code for their own needs, or roll a completely new implementation.
61  .
62  IJS is a client-server protocol, used to write ghostscript drivers. The
63  drivers are separate programs. The client and server communicate via pipes,
64  though shared memory may be used additionally in the future. Currently IJS
65  is used by the hpijs and ijsgimpprint drivers.
66  .
67  Code for both the client- and server-side is included in the library. This
68  package provides a static library, development headers and documentation.
69
70 %prep
71 %setup -q
72
73 %build
74 export CFLAGS="$RPM_OPT_FLAGS"    
75 export CXXFLAGS="$RPM_OPT_FLAGS"    
76
77 %configure\
78     --prefix=/usr\
79     --mandir=/usr/share/man --infodir=/usr/share/info \
80     --enable-shared
81
82 make  %{?_smp_flags} CFLAGS="$CFLAGS"
83 make doc
84
85 %install
86 %makeinstall
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post -p /sbin/ldconfig
92
93 %postun -p /sbin/ldconfig
94
95 %files 
96 %defattr(-,root,root)
97 %doc README
98 %{_libdir}/libijs-0.35.so
99
100 %files devel
101 %defattr(-,root,root)
102 %doc README
103 %{_includedir}/ijs/*.h
104 %{_libdir}/*.so
105 %{_libdir}/*.la
106 %{_libdir}/*.a
107 %{_libdir}/pkgconfig/ijs.pc
108 %{_bindir}/*
109 %{_docdir}/*
110 %{_mandir}/man1/ijs-config.1.gz
111
112 %changelog