add packaging
[platform/upstream/libidn.git] / packaging / libidn.spec
1 Name:           libidn
2 Version:        1.25
3 Release:        0
4 License:        (GPL-2.0+ or LGPL-3.0+) and GPL-3.0+
5 Summary:        Support for Internationalized Domain Names (IDN)
6 Url:            http://www.gnu.org/software/libidn/
7 Group:          System/Libraries
8 Source0:        http://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
9 Source1:        baselibs.conf
10 BuildRequires:  pkgconfig
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
12
13 %description
14 GNU Libidn is an implementation of the Stringprep, Punycode, and IDNA
15 specifications defined by the IETF Internationalized Domain Names (IDN)
16 working group. It is used to prepare internationalized strings (such as
17 domain name labels, usernames, and passwords) in order to increase the
18 likelihood that string input and string comparison work in ways that
19 make sense for typical users around the world. The library contains a
20 generic Stringprep implementation that does Unicode 3.2 NFKC
21 normalization, mapping and prohibition of characters, and bidirectional
22 character handling. Profiles for iSCSI, Kerberos 5, Nameprep, SASL, and
23 XMPP are included. Punycode and ASCII Compatible Encoding (ACE) via
24 IDNA is supported.
25
26 %package devel
27 License:        LGPL-2.1+
28 Summary:        Include Files and Libraries mandatory for Development
29 Group:          System/Libraries
30 Requires:       %{name} = %{version}
31 Requires:       glibc-devel
32
33 %description devel
34 GNU Libidn is an implementation of the Stringprep, Punycode, and IDNA
35 specifications defined by the IETF Internationalized Domain Names (IDN)
36 working group. It is used to prepare internationalized strings (such as
37 domain name labels, usernames, and passwords) in order to increase the
38 likelihood that string input and string comparison work in ways that
39 make sense for typical users around the world. The library contains a
40 generic Stringprep implementation that does Unicode 3.2 NFKC
41 normalization, mapping and prohibition of characters, and bidirectional
42 character handling. Profiles for iSCSI, Kerberos 5, Nameprep, SASL, and
43 XMPP are included. Punycode and ASCII Compatible Encoding (ACE) via
44 IDNA is supported.
45
46 %prep
47 %setup -q
48
49 %build
50 %configure --with-pic --disable-static --disable-gtk-doc
51 make %{?_smp_mflags}
52
53 %check
54 %if ! 0%{?qemu_user_space_build}
55 make check
56 %endif
57
58 %install
59 %make_install
60 rm -f %{buildroot}/%{_infodir}/dir
61 rm -f %{buildroot}%{_libdir}/libidn.la
62 %find_lang %{name}
63
64
65 %post -p /sbin/ldconfig
66
67 %postun
68 /sbin/ldconfig
69
70
71 %lang_package
72
73 %docs_package
74
75 %files
76 %{_libdir}/libidn.so.*
77 %{_infodir}/libidn*
78 %{_bindir}/idn
79 %{_datadir}/emacs/site-lisp/idna.el
80 %{_datadir}/emacs/site-lisp/punycode.el
81
82 %files devel
83 %defattr(-,root,root)
84 %{_libdir}/libidn.so
85 %{_includedir}/*.h
86 %{_libdir}/pkgconfig/libidn.pc
87
88 %changelog