resetting manifest requested domain to floor
[platform/upstream/libidn.git] / packaging / libidn.spec
1 Name:           libidn
2 Version:        1.25
3 Release:        0
4 License:        (GPL-2.0+ or LGPL-3.0+) and GPL-3.0+
5 Summary:        Support for Internationalized Domain Names (IDN)
6 Url:            http://www.gnu.org/software/libidn/
7 Group:          System/Libraries
8 Source0:        http://ftp.gnu.org/gnu/libidn/libidn-%{version}.tar.gz
9 Source1:        baselibs.conf
10 Source1001:     libidn.manifest
11 BuildRequires:  pkgconfig
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
13
14 %description
15 GNU Libidn is an implementation of the Stringprep, Punycode, and IDNA
16 specifications defined by the IETF Internationalized Domain Names (IDN)
17 working group. It is used to prepare internationalized strings (such as
18 domain name labels, usernames, and passwords) in order to increase the
19 likelihood that string input and string comparison work in ways that
20 make sense for typical users around the world. The library contains a
21 generic Stringprep implementation that does Unicode 3.2 NFKC
22 normalization, mapping and prohibition of characters, and bidirectional
23 character handling. Profiles for iSCSI, Kerberos 5, Nameprep, SASL, and
24 XMPP are included. Punycode and ASCII Compatible Encoding (ACE) via
25 IDNA is supported.
26
27 %package devel
28 License:        LGPL-2.1+
29 Summary:        Include Files and Libraries mandatory for Development
30 Group:          System/Libraries
31 Requires:       %{name} = %{version}
32 Requires:       glibc-devel
33
34 %description devel
35 GNU Libidn is an implementation of the Stringprep, Punycode, and IDNA
36 specifications defined by the IETF Internationalized Domain Names (IDN)
37 working group. It is used to prepare internationalized strings (such as
38 domain name labels, usernames, and passwords) in order to increase the
39 likelihood that string input and string comparison work in ways that
40 make sense for typical users around the world. The library contains a
41 generic Stringprep implementation that does Unicode 3.2 NFKC
42 normalization, mapping and prohibition of characters, and bidirectional
43 character handling. Profiles for iSCSI, Kerberos 5, Nameprep, SASL, and
44 XMPP are included. Punycode and ASCII Compatible Encoding (ACE) via
45 IDNA is supported.
46
47 %prep
48 %setup -q
49 cp %{SOURCE1001} .
50
51 %build
52 %configure --with-pic --disable-static --disable-gtk-doc
53 make %{?_smp_mflags}
54
55 %check
56 %if ! 0%{?qemu_user_space_build}
57 make check
58 %endif
59
60 %install
61 %make_install
62 rm -f %{buildroot}/%{_infodir}/dir
63 rm -f %{buildroot}%{_libdir}/libidn.la
64 %find_lang %{name}
65
66
67 %post -p /sbin/ldconfig
68
69 %postun
70 /sbin/ldconfig
71
72
73 %lang_package
74
75 %docs_package
76
77 %files
78 %manifest %{name}.manifest
79 %license COPYING
80 %{_libdir}/libidn.so.*
81 %{_infodir}/libidn*
82 %{_bindir}/idn
83 %{_datadir}/emacs/site-lisp/idna.el
84 %{_datadir}/emacs/site-lisp/punycode.el
85
86 %files devel
87 %manifest %{name}.manifest
88 %defattr(-,root,root)
89 %{_libdir}/libidn.so
90 %{_includedir}/*.h
91 %{_libdir}/pkgconfig/libidn.pc
92
93 %changelog