bd4f5200053f03fb0c5ad299b367a5020fbe0812
[platform/upstream/libical.git] / packaging / libical.spec
1 Name:           libical
2 BuildRequires:  db4-devel
3 BuildRequires:  libtool
4 BuildRequires:  pkg-config
5 BuildRequires:  python-devel
6 Url:            http://sourceforge.net/projects/freeassociation/
7 Version:        0.48
8 Release:        0
9 Summary:        An Implementation of Basic iCAL Protocols
10 License:        MPL-1.1 or LGPL-2.1
11 Group:          Development/Libraries/C and C++
12 Source:         libical-%{version}.tar.bz2
13 Source2:        baselibs.conf
14 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
15
16 %description
17 Libical is an open source implementation of the IETF's iCalendar
18 calendaring and scheduling protocols (RFC 2445, 2446, and 2447). It
19 parses iCal components and provides a C API for manipulating the
20 component properties, parameters, and subcomponents.
21
22 %package devel
23 Summary:        An implementation of basic iCAL protocols
24 Group:          Development/Libraries/C and C++
25 Requires:       libical = %{version}
26
27 %description devel
28 Libical is an Open Source implementation of the IETF's iCalendar
29 Calendaring and Scheduling protocols. (RFC 2445, 2446, and 2447). It
30 parses iCal components and provides a C API for manipulating the
31 component properties, parameters, and subcomponents.
32
33 %package doc
34 Summary:        An Implementation of Basic iCAL Protocols
35 Group:          Development/Libraries/C and C++
36 Requires:       libical = %{version}
37
38 %description doc
39 Libical is an open source implementation of the IETF's iCalendar
40 calendaring and scheduling protocols (RFC 2445, 2446, and 2447). It
41 parses iCal components and provides a C API for manipulating the
42 component properties, parameters, and subcomponents.
43
44 %prep
45 %setup -q
46
47 %build
48 # triger autoreconf since the 0.46 tarball is missing autotools bootstrap files
49 autoreconf -f -i
50 %{configure} \
51         --with-bdb4 \
52         --with-bdb4-dir=%{_prefix} \
53         --without-builtintz \
54         --enable-shared \
55         --disable-static
56 %{__make} %{?_smp_mflags}
57
58 %install
59 %{makeinstall}
60 %{__rm} $RPM_BUILD_ROOT/%{_libdir}/libical*.la
61 %{__rm} doc/Makefile*
62 %{__rm} -rf examples/.deps
63 %{__rm} -rf examples/.libs
64 %{__rm} examples/*.o
65 %{__rm} examples/doesnothing
66 %{__rm} scripts/Makefile*
67 %{__sed} -i -e '1s,.*,#!/usr/bin/perl,' scripts/mkneticali.pl
68
69 %post  -p /sbin/ldconfig
70
71 %postun -p /sbin/ldconfig
72
73 %files 
74 %defattr(-,root,root)
75 %{_libdir}/*.so.*
76
77 %files devel
78 %defattr(-,root,root)
79 %{_libdir}/*.so
80 %{_libdir}/pkgconfig/libical.pc
81 %{_includedir}/ical.h
82 %{_includedir}/libical
83
84 %files doc
85 %defattr(-,root,root)
86 %doc doc examples scripts
87
88 %changelog