Set license using %license
[platform/upstream/libical.git] / packaging / libical.spec
1 Name:           libical
2 BuildRequires:  db4-devel
3 BuildRequires:  libtool
4 BuildRequires:  pkg-config
5 BuildRequires:  python-devel
6 Url:            http://sourceforge.net/projects/freeassociation/
7 Version:        0.48
8 Release:        0
9 Summary:        An Implementation of Basic iCAL Protocols
10 License:        MPL-1.1 or LGPL-2.1
11 Group:          Development/Libraries/C and C++
12 Source:         libical-%{version}.tar.bz2
13 Source2:        baselibs.conf
14
15 %description
16 Libical is an open source implementation of the IETF's iCalendar
17 calendaring and scheduling protocols (RFC 2445, 2446, and 2447). It
18 parses iCal components and provides a C API for manipulating the
19 component properties, parameters, and subcomponents.
20
21 %package devel
22 Summary:        An implementation of basic iCAL protocols
23 Group:          Development/Libraries/C and C++
24 Requires:       libical = %{version}
25
26 %description devel
27 Libical is an Open Source implementation of the IETF's iCalendar
28 Calendaring and Scheduling protocols. (RFC 2445, 2446, and 2447). It
29 parses iCal components and provides a C API for manipulating the
30 component properties, parameters, and subcomponents.
31
32 %package doc
33 Summary:        An Implementation of Basic iCAL Protocols
34 Group:          Development/Libraries/C and C++
35 Requires:       libical = %{version}
36
37 %description doc
38 Libical is an open source implementation of the IETF's iCalendar
39 calendaring and scheduling protocols (RFC 2445, 2446, and 2447). It
40 parses iCal components and provides a C API for manipulating the
41 component properties, parameters, and subcomponents.
42
43 %prep
44 %setup -q
45
46 %build
47 # triger autoreconf since the 0.46 tarball is missing autotools bootstrap files
48 autoreconf -f -i
49 %{configure} \
50         --with-bdb4 \
51         --with-bdb4-dir=%{_prefix} \
52         --without-builtintz \
53         --enable-shared \
54         --disable-static
55 %{__make} %{?_smp_mflags}
56
57 %install
58 %make_install
59 %{__rm} doc/Makefile*
60 %{__rm} -rf examples/.deps
61 %{__rm} -rf examples/.libs
62 %{__rm} examples/*.o
63 %{__rm} examples/doesnothing
64 %{__rm} scripts/Makefile*
65 %{__sed} -i -e '1s,.*,#!/usr/bin/perl,' scripts/mkneticali.pl
66
67 %post  -p /sbin/ldconfig
68
69 %postun -p /sbin/ldconfig
70
71 %files 
72 %defattr(-,root,root)
73 %license COPYING
74 %{_libdir}/*.so.*
75
76 %files devel
77 %defattr(-,root,root)
78 %{_libdir}/*.so
79 %{_libdir}/pkgconfig/libical.pc
80 %{_includedir}/ical.h
81 %{_includedir}/libical
82
83 %files doc
84 %defattr(-,root,root)
85 %doc doc examples scripts
86
87 %changelog