Remove last trailing comma
[platform/framework/web/heap-monitor.git] / packaging / libheap-monitor.spec
1 Name: libheap-monitor
2 Summary: Library for monitoring the heap usage
3 Version: 0.0.13
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10
11 %description
12 Monitoring the heap usage to manage them safely.
13
14 %package devel
15 Summary: Files for implementaion of the heap monitor.
16 Group: Development/Libraries
17 Requires: %{name} = %{version}-%{release}
18
19 %description devel
20 Monitoring the heap usage to manage them safely.(dev)
21
22 %prep
23 %setup -q
24
25 %build
26 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
27 CFLAGS+="${CFLAGS} -fvisibility=hidden -Wall -Werror -Winline -fno-builtin-malloc" make %{?jobs:-j%jobs}
28
29 %install
30 rm -rf %{buildroot}
31 %make_install
32 mkdir -p %{buildroot}/%{_datarootdir}/license
33
34 %post
35
36 %files
37 %manifest libheap-monitor.manifest
38 %defattr(-,root,root,-)
39 %{_libdir}/*.so*
40 %{_datarootdir}/license/*
41
42 %files devel
43 %defattr(-,root,root,-)
44 %{_includedir}/heap-monitor/heap-monitor.h
45 %{_libdir}/pkgconfig/*.pc
46
47 # End of a file