Fix BSD license name
[platform/upstream/libgcrypt.git] / packaging / libgcrypt.spec
1 Name:           libgcrypt
2 Version:        1.6.2
3 Release:        0
4 License:        LGPL-2.1+ and GPL-2.0+
5 Summary:        The GNU Crypto Library
6 %define libsoname %{name}
7 Url:            http://directory.fsf.org/wiki/Libgcrypt
8 Group:          Security/Crypto Libraries
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     libgcrypt.manifest
12 BuildRequires:  libgpg-error-devel >= 1.8
13 BuildRequires:  libtool
14
15 %description
16 Libgcrypt is a general purpose crypto library based on the code used in
17 GnuPG (alpha version).
18
19 %package devel
20 License:        GPL-2.0+ and LGPL-2.1+ and X11 and BSD-3-Clause and IETF
21 Summary:        The GNU Crypto Library
22 Group:          Development/Libraries
23 Requires:       %{libsoname} = %{version}
24 Requires:       glibc-devel
25 Requires:       libgpg-error-devel >= 1.8
26
27 %description devel
28 Libgcrypt is a general purpose crypto library based on the code used in
29 GnuPG (alpha version).
30
31 This package contains needed files to compile and link against the
32 library.
33
34 %prep
35 %setup -q
36 cp %{SOURCE1001} .
37
38 %build
39 # define ciphers to build
40 ENABLE_CIPHER="arcfour blowfish cast5 des aes twofish serpent rfc2268 seed camellia"
41 ENABLE_PUBKEY="dsa elgamal rsa ecc"
42 ENABLE_DIGEST="crc md4 md5 rmd160 sha1 sha256 sha512 tiger whirlpool"
43 #
44 autoreconf -fi
45 %configure --with-pic \
46                 --enable-noexecstack \
47                 --disable-static \
48                 --enable-ciphers="$ENABLE_CIPHER" \
49                 --enable-pubkey-ciphers="$ENABLE_PUBKEY" \
50                 --enable-digests="$ENABLE_DIGEST"
51 make %{?_smp_mflags}
52
53 %check
54 # Nice idea. however this uses /dev/random, which hangs
55 # on hardware without random feeds.
56 #make check
57
58 %install
59 %make_install
60
61 %post  -p /sbin/ldconfig
62
63 %postun -p /sbin/ldconfig
64
65 %files
66 %manifest %{name}.manifest
67 %defattr(-,root,root)
68 %license COPYING COPYING.LIB
69 %{_libdir}/%{name}.so.20*
70
71 %files devel
72 %manifest %{name}.manifest
73 %defattr(-,root,root)
74 %{_infodir}/gcrypt.info.gz
75 %{_infodir}/gcrypt.info-1.gz
76 %{_infodir}/gcrypt.info-2.gz
77 %{_mandir}/man1/hmac256.1.gz
78 %{_bindir}/dumpsexp
79 %{_bindir}/hmac256
80 %{_bindir}/mpicalc
81 %{_bindir}/%{name}-config
82 %{_libdir}/%{name}.so
83 %{_includedir}/gcrypt*.h
84 %{_datadir}/aclocal/%{name}.m4
85
86 %changelog